Bug 437307 - gdm greeter reacts on hot-keys
gdm greeter reacts on hot-keys
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 10:37 EDT by Thomas Woerner
Modified: 2015-01-14 18:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 18:00:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Woerner 2008-03-13 10:37:19 EDT
Description of problem:
gdm greeter reacts on hot-keys, therefore you can minimize the greeter with F9
and you will never get it back without restarting the Xserver.

Version-Release number of selected component (if applicable):
gdm-2.21.9-2.fc9

How reproducible:
Always

Steps to Reproduce:
1. Press F9 if mouse is over greeter.
2. Greeter is minimized.
3.
  
Actual results:
Greeter is minimized.

Expected results:
Not this.

Additional info:
I think it would be useful to disable all hot-keys for the greeter. Moving and
resizing sometimes results in trembling of the greeter.
Comment 1 Thomas Woerner 2008-03-27 07:16:25 EDT
No comment?
Comment 2 Ray Strode [halfline] 2008-03-27 10:21:41 EDT
turning off minimize probably makes sense, since we don't provide a tasklist
(although alt-tab works).

Some hotkeys don't make sense to disable.  We should set the right hints on
windows so they can't be manipulated in ways we don't want them manipulated though.

Note You need to log in before you can comment on or make changes to this bug.