Bug 437341 - removing MMC hangs kernel
removing MMC hangs kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 12:48 EDT by Ulrich Drepper
Modified: 2008-08-24 23:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-24 23:56:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2008-03-13 12:48:48 EDT
Description of problem:
When removing the MMC while the system is running (this is an X61 with
integrated MMC reader) the system hangs.  In the logs it shows

  protection fault: 0000 [1] SMP DEBUG_PAGEALLOC

I cannot see more information, even if it's printed on the console, because the
kernel doesn't restore the backlight on this machine.  So I cannot switch to the
text console before removing the card

Version-Release number of selected component (if applicable):
kernel-2.6.25-0.113.rc5.git2.fc9

and earlier kernels

How reproducible:
always

Steps to Reproduce:
1.insert and mount MMC
2.remove MMC
3.
  
Actual results:
system completely freezes

Expected results:
no freeze

Additional info:
Comment 1 Pete Zaitcev 2008-03-13 15:15:30 EDT
Would it be possible to try netconsole?
Comment 2 Bug Zapper 2008-05-14 02:01:34 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Ulrich Drepper 2008-08-24 23:56:29 EDT
I haven't seen this for quite a while.  Current F9 kernels work.  Closing.

Note You need to log in before you can comment on or make changes to this bug.