This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 437351 - skiplist corruption in cyrus-imapd 2.3.9; please upgrade to latest upstream
skiplist corruption in cyrus-imapd 2.3.9; please upgrade to latest upstream
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Tomas Janousek
Fedora Extras Quality Assurance
http://lists.andrew.cmu.edu/pipermail...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 13:18 EDT by Matt Bernstein
Modified: 2008-04-16 23:57 EDT (History)
0 users

See Also:
Fixed In Version: 2.3.11-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 23:57:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Bernstein 2008-03-13 13:18:38 EDT
Description of problem:

After our mail server crashes, some cyrus-imapd skiplist files need restoring
from backup, notably the seen db files. Also, sync_server seems to SEGV
sporadically. Latest upstream claims to be better (see the URL).

Version-Release number of selected component (if applicable):

cyrus-imapd-2.3.9-7.fc8

How reproducible:

1. hard; I think the mail server crashes thanks to spammers DDoS-ing us..
2. the sync_servers crash after not too much time

Additional info:

I'm happy to test 2.3.11 koji builds (but don't tell my boss), so impact on
others should be minimal. Sorry this is such a crap bug report.
Comment 1 Tomas Janousek 2008-03-13 15:26:27 EDT
Well, I was waiting for the rmquota+deletemailbox patch from uoa to get updated
to 2.3.11, but since that's not happened yet, I'll probably drop it for now and
update to 2.3.11. Simon Matter did the same. Expect a koji build to appear here
in a few days (as soon as I get to it).
Comment 3 Need Real Name 2008-03-27 09:06:20 EDT
Lovely, thanks, I've been bruising it as hard as I can for 24 hours and have no
crashes or corruption :)
Comment 4 Fedora Update System 2008-03-28 04:01:58 EDT
cyrus-imapd-2.3.11-1.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-04-01 17:34:41 EDT
cyrus-imapd-2.3.11-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cyrus-imapd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2837
Comment 6 Fedora Update System 2008-04-16 23:57:46 EDT
cyrus-imapd-2.3.11-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.