Bug 437374 - RFE:system-config-firewall --- backup files
RFE:system-config-firewall --- backup files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 14:48 EDT by Ray Todd Stevens
Modified: 2009-11-11 09:58 EST (History)
0 users

See Also:
Fixed In Version: 1.2.16-3.fc10
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-11 09:58:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2008-03-13 14:48:40 EDT
system-config-firewall is not really very compatible with manually configured
firewalls.  This is documented, and I have no problem with this.   However, it
is very easy to forget that you did a manual update and then overwrite it.  
When you do you don't really have documentation of the original.

How about moving the iptables and up6tables files in sysconfig to
iptables.backup and ip6tables.backup before writing the new ones.   This would
be advantageous both if you forgot that you were doing manual updates on a
server, and also if you do an update and break things to put the back real fast.
Comment 1 Ray Todd Stevens 2008-12-02 18:26:33 EST
Checked this with 10 and it is still an issue.
Comment 2 Ray Todd Stevens 2009-04-02 15:23:42 EDT
This now in and of itself is not an issue as of fc11 beta.   The old versions are saves as .old files.  However, if I were doing it I would also tell people that this had happened as a part of a message during the save process.
Comment 3 Fedora Update System 2009-06-03 08:46:40 EDT
system-config-firewall-1.2.16-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/system-config-firewall-1.2.16-3.fc10
Comment 4 Fedora Update System 2009-06-04 17:20:52 EDT
system-config-firewall-1.2.16-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-firewall'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5928
Comment 5 Ray Todd Stevens 2009-08-31 22:37:22 EDT
I think this one is ready to close and has been for several months now???
Comment 6 Ray Todd Stevens 2009-09-23 13:38:46 EDT
This is label as waiting my testing.   My test results are found in commnet 2.  Basically the problem is fixed, but frankly in a future release I would include a message saying that the old files were backed up with a .old extension.   Other than if you want to keep this around and turn it maybe into a rfe I don't see any reason not to close it.
Comment 7 Fedora Update System 2009-11-11 09:58:14 EST
system-config-firewall-1.2.16-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.