Bug 437378 - cron issue for DOWNLOAD_ONLY=yes
cron issue for DOWNLOAD_ONLY=yes
Status: CLOSED WORKSFORME
Product: Fedora EPEL
Classification: Fedora
Component: yum-cron (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Habig, Alec
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 15:04 EDT by Bryan Gartner
Modified: 2010-09-23 04:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-23 04:44:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Gartner 2008-03-13 15:04:42 EDT
Description of problem:

if DOWNLOAD_ONLY=yes, /etc/cron.daily/yum.cron calls yum with --downloadonly   
option, which doesn't seem to exist in the version of yum
that currently ships with RHEL5.1 (yum-3.0.1-5.el5)

Version-Release number of selected component (if applicable):

yum-cron-0.6-1.el5

How reproducible:

Steps to Reproduce:
1. set DOWNLOAD_ONLY=yes in /etc/sysconfig/yum-cron
2. /etc/init.d/yum-cron restart
3.5 optionally remove -R 120 for quicker test in /etc/cron.daily/yum-cron
3. run /etc/cron.daily/yum.cron >/dev/null
  
Actual results:

Command line error: no such option: --downloadonly

Expected results:

Updates downloaded, use "yum -C update" manually to install them.

Additional info:

just substituting

s/--downloadonly update/makecache/

seems to work in my test case
Comment 1 James Antill 2008-03-13 15:24:13 EDT
 yum-cron gets that functionality from "yum-downloadonly", you can just install
that package yourself until then (it's available in 5.1 onwards).

 Note that makecache doesn't download any of the packages.
Comment 2 Habig, Alec 2008-03-13 15:54:41 EDT
Later versions of yum-cron (which I haven't been pushing to EPEL since yum-cron
is a core CentOS package that we're not supposed to override in EPEL) fix this
by requiring yum-downloadonly in the rpm requirements list.

If you're interested in newer versions of this package, grab one out of an F-7
or newer repository.  They'll work just fine on EL-5, we just can't push the
updates there.

Will change this to ASSIGNED and investigate the simultaneous export of a newer
version to both EPEL and CentOS.
Comment 3 Bryan Gartner 2008-03-14 00:02:30 EDT
(In reply to comment #1)
>  yum-cron gets that functionality from "yum-downloadonly", you can just install
> that package yourself until then (it's available in 5.1 onwards).

Okay, good to know, but shouldn't the yum-cron package then have such a
dependency at the package level ?

>  Note that makecache doesn't download any of the packages.

Good point, thanks for pointing that out 

Comment 4 Bryan Gartner 2008-03-14 00:04:53 EDT
(In reply to comment #2)
> Later versions of yum-cron (which I haven't been pushing to EPEL since yum-cron
> is a core CentOS package that we're not supposed to override in EPEL) fix this
> by requiring yum-downloadonly in the rpm requirements list.

Oops, guess I should have read all the replies.  At least I know the reason now.

> If you're interested in newer versions of this package, grab one out of an F-7
> or newer repository.  They'll work just fine on EL-5, we just can't push the
> updates there.
> 
> Will change this to ASSIGNED and investigate the simultaneous export of a newer
> version to both EPEL and CentOS.

Thanks for all your help.


Comment 5 Bryan Gartner 2008-03-14 00:11:01 EDT
Okay, so after checking again on the system in question,

yum-downloadonly-1.0.4-3.el5

was already installed (with basically only RHEL and EPEL repositories
accessible). I guess I am still a bit confused, and don't see a clear solution
without enabling either CentOS or general Fedora repositories.
 
Comment 6 Habig, Alec 2008-03-19 14:09:26 EDT
Hmm - on the most comparable system I've got, FC6 (yum 3.0.6 and
yum-downloadonly 1.0.3), things work for me.  The yum-downloadonly package's
whole purpose in life, from the rpm description, is:

  This plugin adds a --downloadonly flag to yum so that yum will only download
the packages and not install/update them.

so I'm puzzled why the plugin isn't doing what it claims.  It's part of
yum-utils, perhaps the yum-utils mother package isn't installed?  Do you have
any other yum plugins installed that do (or don't) work?
Comment 7 Habig, Alec 2008-03-19 14:13:55 EDT
Something to check.  In /etc/yum.conf, do you have plugins enabled?  ie, is

  plugins=1

somewhere in there?

That's the default in Fedora, I'm not sure what it might be in EL-5.
Comment 8 Mark Chappell 2010-09-23 04:44:11 EDT
I've just followed the instructions in your report on a clean CentOS 5.5 box.

* plugins=1 is the default
* yum-cron does require yum-download
* "/usr/bin/yum -e 0 -d 0 -y --downloadonly update" doesn't error

On the grounds that over 2 years later Bryan hasn't replied, and I'm unable to reproduce the error, I'm going to close off the ticket.

Bryan if this is still an issue feel free to reopen the ticket.

Note You need to log in before you can comment on or make changes to this bug.