Bug 437391 - RT2500 from kernel-2.6.23.15-137.fc8 - no power LED
RT2500 from kernel-2.6.23.15-137.fc8 - no power LED
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i386 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 16:02 EDT by Ivan Virgili
Modified: 2009-01-22 16:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 16:23:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Dump of the register (5.11 KB, text/plain)
2009-01-15 16:30 EST, Ivan Virgili
no flags Details

  None (edit)
Description Ivan Virgili 2008-03-13 16:02:23 EDT
Up to kernel-2.6.23.15-137.fc8 the link LED did not work, but the power LED
worked. From kernel-2.6.23.15-137.fc8 onwards the link LED started working, but
the power LED stopped working.
Comment 1 Ivan Virgili 2008-03-26 16:36:08 EDT
Just got hold of a brand new RT2500 pmcia card and I am still experiencing the
same problem (on the same laptop).
Comment 2 Ivan Virgili 2008-04-16 16:22:31 EDT
Just an update.
Installed kernels 2.6.24.4-74.fc8 and 2.6.24.4-82.fc8.
Problem still not solved.
Comment 3 Ivo van Doorn 2008-04-21 09:25:43 EDT
Just found an obvious typo in the led handling in rt2x00.
This fix should fix both the activity as well as the radio led.
Patch will be pushed to mainstream in 1 or 2 days.
Comment 4 Ivo van Doorn 2008-04-21 13:07:22 EDT
I have pushed the patch a day earlier. :)

John, the patch is part of the 2.1.5 release series,
more specifically patch: "[PATCH 5/9] rt2x00: Fix quality/activity led 
handling"
Hopefully that patch resolves this issue. :)
Comment 5 John W. Linville 2008-05-20 15:18:01 EDT
Is this problem still happening with the latest f8 kernels?
Comment 6 Ivan Virgili 2008-05-20 15:41:13 EDT
I installed F9 two days ago, therefore I cannot test F8 anymore.

On F9 kernel 2.6.25.3-18.fc9.i686 the problem is still happening.
Comment 7 John W. Linville 2008-05-20 15:46:09 EDT
Can you recreate this issue with the kernels here?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=49743
Comment 8 Ivan Virgili 2008-05-20 17:36:53 EDT
Installed kernel 2.6.25.4-26.fc9.i686 but the system freezes as soon as the
network card is activated. It looks as if the power LED does not work anyway,
because only the link LED goes on.
Comment 9 Ivan Virgili 2008-06-01 12:18:17 EDT
Installed kernel kernel-2.6.25.4-39.fc9
System starts fine, network detected, but it does no manage to connect (it
connects fine with kernel 2.6.25.3-18.fc9.i686).
Power LED still not working.
Comment 10 John W. Linville 2008-11-20 14:12:26 EST
Does the problem persist with 2.6.27-based kernels?
Comment 11 Ivan Virgili 2008-11-23 08:16:22 EST
I still have the PCMCIA card, but I do not have the laptop I used to test it with any more. I will give you an update as soon as possible (I should have another laptop to test it with in a week or so).
Comment 12 Ivan Virgili 2008-11-25 16:21:26 EST
Just tested on kernel-2.6.27.5-117.fc10 and the problem persists.
Comment 13 John W. Linville 2008-12-04 10:58:41 EST
This is just the power LED not working, correct?
Comment 14 Ivan Virgili 2008-12-04 14:21:23 EST
Yes, it is just power LED that is not working.
I have just tested the card on another laptop running F10 and it does not work on that either.
Comment 15 John W. Linville 2009-01-13 14:50:00 EST
Ivo, is this patch likely to help here?

commit cae4fff27e845b0d74b2cfe5c635cd4e8eb6fc71
Author: Andrew Price <andy@andrewprice.me.uk>
Date:   Sat Jan 10 19:38:05 2009 +0000

    rt2400,rt2500: init led_qual for LED_MODE_DEFAULT

    Add a check for LED_MODE_DEFAULT so that we use the link LED for rt2400
    and rt2500 devices.

    Signed-off-by: Andrew Price <andy@andrewprice.me.uk>
    Acked-by: Ivo van Doorn <IvDoorn@gmail.com>
    Signed-off-by: John W. Linville <linville@tuxdriver.com>
Comment 16 Ivo van Doorn 2009-01-13 16:42:48 EST
Don't think so, the power LED was registered by default and hence should be toggled by default. The above patch would fix the link LED, rather then the power LED, while the link LED is working for Ivan.

Ivan, could you try mounting debugfs and using http://kernel.org/pub/linux/kernel/people/ivd/tools/rt2x00_regdump.sh to make a dump of the registers?
Perhaps that might show something interesting about the LED type.
Comment 17 Ivan Virgili 2009-01-15 16:30:54 EST
Created attachment 329145 [details]
Dump of the register
Comment 18 Ivo van Doorn 2009-01-15 17:23:42 EST
Thanks,
The LED type is "ASUS" (not very descriptive about what to expect from the led :S)

The original drivers were always treating that type very specially, and I need to check if I ported that correctly. I'll get back on this in a few days.
Comment 19 Ivo van Doorn 2009-01-17 17:43:09 EST
I have send a patch upstream which should fix this issue, the original code is a bit vague since it suggests that led type "ASUS" means that there is only 1 LED, namely the activity LED.

The patch will register both power and activity LEDs, so hopefully that will work as expected.
Comment 20 John W. Linville 2009-01-21 16:48:39 EST
I've added this and a related patch to the kernel being built here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=79697

Please give that a try when the build complete and post the results here...thanks!
Comment 21 John W. Linville 2009-01-22 14:19:48 EST
Kernels from comment 20 have been built successfully.  Please give them a try!
Comment 22 Ivan Virgili 2009-01-22 15:50:38 EST
Well done everyone... You can close this bug...
Both LEDs are on now (connection one flashing, of course)...
Now we just need to make it connect... see:
Fedora 10 - https://bugzilla.redhat.com/show_bug.cgi?id=473432
Fedora 9 - https://bugzilla.redhat.com/show_bug.cgi?id=457441

Note You need to log in before you can comment on or make changes to this bug.