Bug 437395 - ifcfg-eth0 ONBOOT=no incorrectly autoconnects
ifcfg-eth0 ONBOOT=no incorrectly autoconnects
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 16:17 EDT by Warren Togami
Modified: 2008-03-25 09:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 09:09:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2008-03-13 16:17:23 EDT
[root@caprica ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Intel Corporation 82540EP Gigabit Ethernet Controller (Mobile)
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:11:25:d4:83:bb
ONBOOT=no
DHCP_HOSTNAME=caprica

I deleted "Auto Ethernet" from gconf.

Bug: Plugging in Ethernet cable still automatically connects despite ONBOOT=no.
 This is a bug according to dcbw.
Comment 1 Warren Togami 2008-03-13 18:27:02 EDT
Dan figured out that this happens because inotify is watching the file in
/etc/sysconfig/networking/profiles instead of network-scripts/, meaning inotify
only triggers a re-parse of the ifcfg file if system-config-network made the
change which then hardlinks the file from the profile into network-scripts/.  He
is considering having NM look directly at network-scripts but there were other
issues having to do with search domain and hostname that need to be figured first.
Comment 2 Warren Togami 2008-03-24 16:12:22 EDT
Dan this should be fixed now right?
Comment 3 Dan Williams 2008-03-25 09:09:10 EDT
Yeah, should be fixed in latest koji F9 NM to read from
/etc/sysconfig/network-scripts/, not from /.../profiles/default, which was the
issue here.

Note You need to log in before you can comment on or make changes to this bug.