Bug 437399 - /usr/share/tcl8 and /usr/share/tcl8/8.{4,5} are not owned
/usr/share/tcl8 and /usr/share/tcl8/8.{4,5} are not owned
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tcl (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 16:58 EDT by Robert Scheck
Modified: 2008-06-28 18:16 EDT (History)
0 users

See Also:
Fixed In Version: 8.5.2-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-28 18:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-03-13 16:58:27 EDT
Description of problem:
The directories /usr/share/tcl8 and /usr/share/tcl8/8.{4,5} are not owned by 
anything, but they should be definately owned by tcl as this package puts the 
content into.

Version-Release number of selected component (if applicable):
tcl-8.5.1-2

How reproducible:
Everytime, see above.

Actual results:
/usr/share/tcl8 and /usr/share/tcl8/8.{4,5} are not owned.

Expected results:
Owned directories. Please apply the following patch or better:

--- tcl.spec       2008-02-19 15:33:53.000000000 +0100
+++ tcl.spec.rsc   2008-03-13 21:49:46.000000000 +0100
@@ -103,8 +103,7 @@
 %defattr(-,root,root,-)
 %{_bindir}/tclsh*
 %{_datadir}/%{name}%{majorver}
-%{_datadir}/%{name}8/%{majorver}/*
-%{_datadir}/%{name}8/8.4/*
+%{_datadir}/%{name}8
 %{_libdir}/lib%{name}%{majorver}.so
 %{_mandir}/man1/*
 %{_mandir}/man3/*
Comment 1 Robert Scheck 2008-04-23 04:31:01 EDT
No, this is definately NOT fixed in Rawhide, error: Failed dependencies:
  /usr/share/tcl8/8.4 is needed by tcl-8.5.1-4.i386
  /usr/share/tcl8/8.5 is needed by tcl-8.5.1-4.i386
Comment 2 Robert Scheck 2008-05-21 15:32:11 EDT
No, still NOT fixed in Rawhide, error: Failed dependencies:
  /usr/share/tcl8/8.4 is needed by tcl-8.5.2-1.i386
  /usr/share/tcl8/8.5 is needed by tcl-8.5.2-1.i386
Comment 3 Fedora Update System 2008-06-26 02:26:31 EDT
tcl-8.5.2-1.fc9 has been submitted as an update for Fedora 9
Comment 4 Fedora Update System 2008-06-28 18:16:25 EDT
tcl-8.5.2-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.