Bug 437402 - accessing Jamendo causes traceback and browser is not shown nor music played
accessing Jamendo causes traceback and browser is not shown nor music played
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 17:07 EDT by Michal Nowak
Modified: 2013-03-07 21:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 07:06:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 523679 None None None Never

  None (edit)
Description Michal Nowak 2008-03-13 17:07:24 EDT
Description of problem:

While trying to listen music from Jamendo I got in terminal following traceback:

Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/jamendo/JamendoSource.py", line 185, in
__load_catalogue_read_cb
    parser.feed(data)
  File "/usr/lib/python2.5/site-packages/_xmlplus/sax/expatreader.py", line 220,
in feed
    self._err_handler.fatalError(exc)
  File "/usr/lib/python2.5/site-packages/_xmlplus/sax/handler.py", line 38, in
fatalError
    raise exception
xml.sax._exceptions.SAXParseException: <unknown>:268525:0: not well-formed
(invalid token)

Well, rhythmbox didn't update for some time so I suspect some new XML parsing
library causes this.

It seems that the catalog is downloaded but while parsing it something bad
happen and browset is not shown nor any music from Jamendo can be played.

Version-Release number of selected component (if applicable):

rhythmbox-0.11.3-7.fc8

dhcp-lab-110 proj2 # rpmquery -a | grep -i xml
libxml2-python-2.6.31-1.fc8
libxml2-2.6.30-1
xml-common-0.6.3-21.fc8
xmlrpc3-client-3.0-1jpp.4.fc8
xmlto-0.0.18-17
libxml2-2.6.31-1.fc8
perl-XML-RegExp-0.03-2.fc8.1
xmltex-20020625-8
xml-commons-resolver-1.1-1jpp.12
perl-XML-XQL-0.68-4.fc7
xml-commons-apis-1.3.04-0jpp.1.fc8
perl-XML-RSS-1.31-1.fc8
python-lxml-2.0.2-1.fc8
xmlrpc3-common-3.0-1jpp.4.fc8
perl-XML-Parser-2.34-8
libxml2-python-2.6.30-1
perl-XML-DOM-1.44-2.fc8.1
PyXML-0.8.4-7

How reproducible:
always

Steps to Reproduce:
1. try to play music from Jamendo

Actual results:
traceback

Expected results:
music from Jamendo

Additional info:

dhcp-lab-110 proj2 # grep -i xml /var/log/yum.log
Mar 12 22:01:04 Installed: PyXML - 0.8.4-7.i386
Mar 12 22:01:06 Installed: perl-XML-RegExp - 0.03-2.fc8.1.noarch
Mar 12 22:01:08 Installed: perl-XML-DOM - 1.44-2.fc8.1.noarch
Mar 12 22:01:13 Installed: perl-XML-XQL - 0.68-4.fc7.noarch
Mar 13 17:39:26 Installed: python-lxml - 2.0.2-1.fc8.i386
Comment 1 Bastien Nocera 2008-03-13 17:33:31 EDT
Any chance you could revert the PyXML and python-lxml updates, and let me know
whether it fixes your problem?
Comment 2 Michal Nowak 2008-03-13 18:07:51 EDT
python-lxml-1.3.6-1.fc8

PyXML-0.8.4-7
libxml2-2.6.30-1
libxml2-python-2.6.30-1


it is the same, catalog is loading and loading...

with

libxml2-2.6.31-1.fc8
libxml2-python-2.6.31-1.fc8

is the same.
--

Frankly speaking the whole error msg is:

(rhythmbox:5114): Rhythmbox-WARNING **: Failed to invoke RequestName: Connection
":1.74" is not allowed to own the service "org.gnome.Rhythmbox" due to SELinux
policy

(rhythmbox:5114): Rhythmbox-WARNING **: Got unhandled reply 12609221 from
RequestName

(rhythmbox:5114): Rhythmbox-WARNING **: Unable to start mDNS browsing: MDNS
service is not running
Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/jamendo/JamendoSource.py", line 185, in
__load_catalogue_read_cb
    parser.feed(data)
  File "/usr/lib/python2.5/xml/sax/expatreader.py", line 211, in feed
    self._err_handler.fatalError(exc)
  File "/usr/lib/python2.5/xml/sax/handler.py", line 38, in fatalError
    raise exception
xml.sax._exceptions.SAXParseException: <unknown>:268525:0: not well-formed
(invalid token)

(rhythmbox:5114): Rhythmbox-WARNING **: Unable to stop mDNS browsing: MDNS
service is not running

--
add PyXML, I believe it was recently installed due to inkscape, so not sure
whether it's somehow conjuncted with rhythmbox.
Comment 3 Bastien Nocera 2008-03-13 18:36:43 EDT
I can't reproduce it here on a slightly modified F8 machine. Could you remove
~/.gnome2/rhythmbox/jamendo/dbdump.en.xml and try starting up Rhythmbox again?

It's possible that it's a broken cache causing the problem.
Comment 4 Michal Nowak 2008-03-14 05:59:48 EDT
I am facing it on RHEL-5.2 machine too the error msg is similar 

Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/jamendo/JamendoSource.py", line 191, in
__load_catalogue_read_cb
    parser.feed(data)
  File "/usr/lib/python2.4/site-packages/_xmlplus/sax/expatreader.py", line 220,
in feed
    self._err_handler.fatalError(exc)
  File "/usr/lib/python2.4/site-packages/_xmlplus/sax/handler.py", line 38, in
fatalError
    raise exception
xml.sax._exceptions.SAXParseException: <unknown>:268525:0: not well-formed
(invalid token)

and removing the Jamendo DB didn't help there. I'll try it later on my F8 box
too but I predict it won't help there too.

I also moved the rhythmbox'es config dir but it didn't do the job neither.
Comment 5 Michal Nowak 2008-03-14 06:06:52 EDT
But the rhythmbox version I have there is not supported

rhythmbox-0.10.1-1.fc6
--

On RHEL-52 box.
newman@dhcp-lab-198 ~ $ rpmquery -a | grep -i xml
xml-commons-apis-1.3.02-0.b2.7jpp.10
xml-commons-resolver-1.1-1jpp.12
PyXML-0.8.4-4
xmlrpc-javadoc-2.0.1-3jpp.1
xml-commons-1.3.02-0.b2.7jpp.10
libxml2-python-2.6.26-2.1.2.1
xml-common-0.6.3-18
xmltex-20020625-8
xmlto-0.0.18-13.1
xmlrpc-2.0.1-3jpp.1
libxml2-2.6.26-2.1.2.1
Comment 7 Bastien Nocera 2008-03-14 11:48:39 EDT
Could you copy/paste the lines you have around line 268525 of
~/.gnome2/rhythmbox/jamendo/dbdump.en.xml ?

Also could you make sure you remove ~/.gnome2/rhythmbox/jamendo/dbdump.en.xml.tmp?

If this still happens, could you upload the gzipped file somewhere for me to
check, as I can't find that string in the database when downloading the file by
hand...
Comment 8 Michal Nowak 2008-03-15 06:43:06 EDT
1.

deleting of ~/.gnome2/rhythmbox/jamendo/dbdump.en.xml did not help.

2. from vim, with the ^M (CR) garbage

268515 Come on just like me^M
268516 Looking for you looking for me tonight^M
268517 ^M
268518 Gonna see my baby I don’t mean maybe^M
268519 She’s looking so good now she’s driving me crazy^M
268520 ^M
268521 And I know by the look in her eye^M
268522 That I I’m a lucky guy^M
268523 And she keeps telling me^M
268524 She’s ready to go so come on with me^M
268525 ^M
268526 She’s looking so good I’m feeling so fine^M
268527 Tonight’s the night I’m gonna make her mine^M
268528 ^M
268529 And I know by the pale moonlight^M
268530 Tonight’s gonna be the night^M
268531 And she keeps telling me^M
268532 She’s ready for love so come on with me</lyrics></track><track lengths="1
      71" albumID="20827" trackno="6" link="http://www.jamendo.com/track/146366
      /" id="146366"><dispname>penguin - no scratchin</dispname><lyrics></lyric
      s></track><track lengths="270" albumID="20842" trackno="4" link="http://w
      ww.jamendo.com/track/146369/" id="146369"><dispname>Lost in a Storm</disp
      name><lyrics>A long time ago in another life ^M

3. 

never seen the tmp file in ~/.gnome2/rhythmbox/jamendo/

4. 

you are free to use the RHTS box I provided in comment 6, the problem occurs
there too.
Comment 9 Michal Nowak 2008-03-21 07:04:27 EDT
Any progress there? Do you need the box from comment #6 or I can return it?
Comment 10 Bastien Nocera 2008-03-25 07:06:01 EDT
I can't reproduce the problem, but it's been reported upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=523679

Debugging will happen there now.
Comment 11 Bastien Nocera 2008-04-07 05:17:05 EDT
Was mentioned as a problem on the Jamendo side, and fixed.
http://bugzilla.gnome.org/show_bug.cgi?id=523679

Note You need to log in before you can comment on or make changes to this bug.