Bug 437406 - tty[0-6] should not start until after prefdm is up
tty[0-6] should not start until after prefdm is up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: event-compat-sysv (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-03-13 17:27 EDT by Will Woods
Modified: 2014-06-18 04:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 00:06:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-03-13 17:27:58 EDT
When the system starts, tty[0-6] get started at the end of rc5 - at the same
time as prefdm. Since they're faster to start than gdm/kdm/etc, you see a login
prompt briefly, and then GDM starts.

It would improve the polish of the system if they didn't start until after
prefdm was up.

changing 'start on stopped rc5' to 'start on started prefdm' works when rhgb is
running, but without it upstart considers prefdm started before gdm manages to
up X. Racy!
Comment 1 Bill Nottingham 2008-03-13 17:49:59 EDT
Do we really need to change all of them, or is tty1 enough? 
Comment 2 Casey Dahlin 2008-03-13 20:55:44 EDT
The problem with this is you don't get any tty when prefdm isn't running
(runlevel 3).
Comment 3 Bill Nottingham 2008-03-13 22:46:18 EDT
As long as you only replace the 'start on stopped rc5' entry with the one for
prefdm, it should work.
Comment 4 Casey Dahlin 2008-03-14 00:53:17 EDT
Just thought of that.

Repairing my test box now. Some of the new rpm temp file checking stuff is
making init segfault X(
Comment 5 Casey Dahlin 2008-03-17 00:06:22 EDT
fixed in event-compat-sysv-0.3.9-10

Note You need to log in before you can comment on or make changes to this bug.