Bug 43741 - Look up table of IME behavior is different with Sawfish and Enlightment.
Look up table of IME behavior is different with Sawfish and Enlightment.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.0J
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-06 18:48 EDT by IBM Bug Proxy
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 09:56:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2001-06-06 18:48:33 EDT
LTC130	
Look up table of IME  behavior is deferent with Sawfish and Enlightment.

While DBCS Japanese is inputted , 
The candidate of the changed character appears on Lookup Table.
When for example a root window such as editor application was moved.
The lookup table does not follow with application. 
This matter occurs only on Sawfish of Window Manager. 
On Enlightment, It follows with application. Though this is not a big
problem, 
But, the lookup table should follow with application.

OS: Sawfish windows manager on Linux
      e.g. TurboLinux Server 6.5Japanese, 
        TurboLinux 6.0Japanese Workstation
        Redhat 7.1 Japanee

A reproduce process is as follows.
    1. Open kterm
    2. Active IM (canna or FreeWnn) ( Shift+Space )
    3. Type "kyou"
    4. Show Lookup table ( Press Space twice )
    5. Move the root window (kterm)   
       Then, the Lookup table doesn't follow with kterm 
                <---This is strange. It should follow with kterm.
Comment 1 David Mason 2001-06-07 09:56:00 EDT
I thought this was a feature in sawfish... the idea being that when you move a
window, its children (or windows you have placed in the same group) will move
with it.  hp?
Comment 2 Havoc Pennington 2001-06-07 11:24:27 EDT
The issue is that Enlightenment moves dialog windows along with their parent. 
I think in most cases this was bad (e.g. for a file dialog). We can't really
special-case the lookup window. So we'd like to keep the current sawfish behavior.

Note You need to log in before you can comment on or make changes to this bug.