Bug 437422 - s3virge_drv.so: undefined symbol: PCI_REGION_MEM
s3virge_drv.so: undefined symbol: PCI_REGION_MEM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-s3virge (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 19:15 EDT by Kevin Kofler
Modified: 2008-03-18 13:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 13:31:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2008-03-13 19:15:16 EDT
Description of problem:
I tried running a KDE live CD taken from 20080312 Rawhide on my old laptop 
with an S3 Virge MX GPU. X11 failed to start up with this error:
X: symbol lookup error: /usr/lib/xorg/modules/drivers//s3virge_drv.so: 
undefined symbol: PCI_REGION_MEM

Version-Release number of selected component (if applicable):
xorg-x11-drv-s3virge-1.9.1-7.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Just try running X on an S3 Virge chipset. To get the error message onto a 
terminal, run startx from a text login.
  
Actual results:
X: symbol lookup error: /usr/lib/xorg/modules/drivers//s3virge_drv.so: 
undefined symbol: PCI_REGION_MEM

Expected results:
No error.

Additional info:
Interestingly, the Xorg.0.log goes up to:
(--) S3VIRGE(0): Chipset: "virge mx"
(--) S3VIRGE(0): XVideo not supported.
(II) S3VIRGE(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 
0x0000
(I copied this by hand from the laptop screen, that's why I don't have the 
whole file), then abruptly ends as X11 crashes with the above undefined symbol 
error.

Note:
I've set Severity to "high" because this crashes X11 entirely, but I've left 
Priority at "low" because I may well be the only one who still cares about 
that chipset. ;-)
Comment 1 Kevin Kofler 2008-03-16 23:04:19 EDT
This has already been fixed upstream:
http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-s3virge.git;a=commitdiff;h=cda576024eb76835dfb08dd17ebe6c6c6b84769c

Can this please be pulled into F9 ASAP?
Comment 2 Adam Jackson 2008-03-18 13:31:33 EDT
This looks like it's already included in s3virge 1.9.1-8.

Note You need to log in before you can comment on or make changes to this bug.