Bug 437424 - OOo programs exit immediately on nouveau
OOo programs exit immediately on nouveau
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 19:56 EDT by Horst H. von Brand
Modified: 2008-04-17 22:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 22:29:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
*.dmp file created in /tmp here (55.31 KB, application/octet-stream)
2008-03-13 19:56 EDT, Horst H. von Brand
no flags Details
Output of strace -f oocalc (1.15 MB, text/plain)
2008-03-13 19:58 EDT, Horst H. von Brand
no flags Details
Requested xorg.conf (3.55 KB, application/octet-stream)
2008-03-27 17:57 EDT, Horst H. von Brand
no flags Details
Xorg.0.log with xorg.conf (nouveau) (88.31 KB, text/plain)
2008-03-27 17:58 EDT, Horst H. von Brand
no flags Details
Xorg.0.log, no xorg.conf at all (33.19 KB, text/plain)
2008-03-27 18:07 EDT, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2008-03-13 19:56:32 EDT
Description of problem:
Running any of oocalc, oowriter, ooimpress exits immediately.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.4.0-10.1.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
An strace shows that a *.dmp file (binary) is created in /tmp

Expected results:


Additional info:
I'm pretty sure I used one of them after the last update, so this might not be
OOo directly.
Comment 1 Horst H. von Brand 2008-03-13 19:56:32 EDT
Created attachment 298002 [details]
*.dmp file created in /tmp here
Comment 2 Horst H. von Brand 2008-03-13 19:58:30 EDT
Created attachment 298003 [details]
Output of strace -f oocalc

The strace output that helped identify the file attached to the bug
Comment 3 Caolan McNamara 2008-03-14 04:23:10 EDT
No, something weird here, loads of write and seek to fd 10, searching backwards
from end on for = 10$ indeed shows [pid 10619]
open("/tmp/21d540d4-96d0-e597-235674eb-50388e3d.dmp", O_WRONLY|O_CREAT|O_EXCL,
0600) = 10
but the creation of that is weird, ie.

[pid 10619] --- SIGSEGV (Segmentation fault) @ 0 (0) ---
...
[pid 10619] access("/usr/bin/gdb", X_OK) = 0
...

So something is crashing, and calling gdb and making that dump file. Our normal
handler is the OOo crash dialog, so either we haven't gotten as far as setting
our handler or it is some forked and execed thingy.

Anyway, what's your X video driver ? It is nouveau or something exotic, and does
it make a difference to try e.g. nv/vesa. The segv comes right after some
fiddling with /dev/dri/card0
Comment 4 Caolan McNamara 2008-03-14 04:50:52 EDT
If it is some opengl foo, then perhaps export SAL_NOOPENGL=1 may workaround by
disabling use of opengl
Comment 5 Horst H. von Brand 2008-03-14 14:09:41 EDT
Nope, "SAL_NOOPENGL=1 oowriter" exits just the same.

Video driver is nouveau. Will try later with the other suggestions.
Comment 6 Horst H. von Brand 2008-03-15 10:28:41 EDT
I forgot that starting Gnome gives error messages. I don't know where I can find
logs on them. Maybe that is the root cause?
Comment 7 Horst H. von Brand 2008-03-15 10:54:32 EDT
Just tried the nv driver, oocalc opens normally.
Comment 8 antonio montagnani 2008-03-15 16:07:32 EDT
I confirm what Horst is saying.

nv driver is o.k, but with nouveau no way of starting oowriter and oocalc
Comment 9 Caolan McNamara 2008-03-16 16:14:12 EDT
I'd be interested in anything else fails to startup, e.g. maybe glxglears and so
forth ? And then the version of the nouveau driver in question
Comment 10 Horst H. von Brand 2008-03-17 13:40:00 EDT
xorg-x11-drv-nouveau-0.0.10-1.20080221git5db7920.fc9.i386, installed Fri 29 Feb
2008 05:17:13 PM CLST. This definitely predates the crash (I don't use OOo that
much, but it was working before the day I reported it). Haven't tried nouveau again.
Comment 11 Matěj Cepl 2008-03-18 05:37:21 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 12 Horst H. von Brand 2008-03-27 17:57:37 EDT
Created attachment 299394 [details]
Requested xorg.conf

This is the file using nouveau. oowriter ends immediately, glxgears segfaults.
Comment 13 Horst H. von Brand 2008-03-27 17:58:37 EDT
Created attachment 299395 [details]
Xorg.0.log with xorg.conf (nouveau)
Comment 14 Horst H. von Brand 2008-03-27 18:07:12 EDT
Created attachment 299398 [details]
Xorg.0.log, no xorg.conf at all

Now oowriter and glxgears work fine. The keyboard is messed up, however (US
layouy, should be Spanish)
Comment 15 Horst H. von Brand 2008-03-27 18:48:26 EDT
Looking at the Xorg.0.log file without xorg.conf, it autodetects the nv driver.
That configuration used to work before too.
Comment 16 Dave Airlie 2008-04-17 22:29:03 EDT
closing, sounds like the problem with software GL being broken.

Note You need to log in before you can comment on or make changes to this bug.