Bug 437432 - Can not send icmp netunreach packet
Can not send icmp netunreach packet
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 00:15 EDT by Li Yewang
Modified: 2008-03-19 12:47 EDT (History)
0 users

See Also:
Fixed In Version: 2.6.24.3-12.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 12:47:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for fix this bug (464 bytes, text/plain)
2008-03-14 00:15 EDT, Li Yewang
no flags Details

  None (edit)
Description Li Yewang 2008-03-14 00:15:24 EDT
Description of problem:
   There is a bug about icmp netunreach.
   If the kernel does not find a route for a packet, 
   it must send a icmp netunreach packet to the source host, 
   and  discard  the packet. But the  kernel  does not send 
   a icmp netunreach packet because of the  fib_lookup
   return value  of -ESRCH when a route  is not found. 

Version-Release number of selected component (if applicable):
Fedora8 (2.6.23.1-42.fc8)

How reproducible:

TN ---------------------NUT

Steps to Reproduce:
1.  TN send a echo request to a unknown dest address to NUT
2.  
3.
  
Actual results:
TN can not receive netunreach packet packet

Expected results:
TN can receive netunreach packet packet

Additional info:
Comment 1 Li Yewang 2008-03-14 00:15:24 EDT
Created attachment 298014 [details]
patch for fix this bug
Comment 2 Chuck Ebbert 2008-03-14 18:19:51 EDT
Already fixed in 2.6.24 (but not 2.6.23.17)
Comment 3 Chuck Ebbert 2008-03-19 12:47:56 EDT
Closing as CURRENTRELEASE since 2.6.24.3-12 did not have this bug.

Note You need to log in before you can comment on or make changes to this bug.