Bug 437446 - lvm lvs hangs - suspect clvmd to be the cause
lvm lvs hangs - suspect clvmd to be the cause
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
5.2
All Linux
urgent Severity high
: rc
: ---
Assigned To: Milan Broz
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 05:00 EDT by Lutz Lange
Modified: 2013-02-28 23:06 EST (History)
9 users (show)

See Also:
Fixed In Version: RHBA-2008-0379
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:26:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lutz Lange 2008-03-14 05:00:03 EDT
Description of problem:
Running RHEL-5.2 with lvm2-2.02.32-1.el5 and lvm2-cluster-2.02.32-1.el5

Installing a new kernel hangs for ever.
Investigation shows that mkinitrd is startet but never succeeds.
pstree shows that the command lvm.static lvs ... is the cause.

Version-Release number of selected component (if applicable):

Downgrading to lvm2-2.02.26-3.el5 and lvm2-cluster-2.02.26-1.el5 does not yet
fix the problem. But killing (kill -9 clvmd) and starting clvmd anew will make
it go away.
Comment 1 Christine Caulfield 2008-03-18 13:18:10 EDT
There's a distinct possibility that this is the same as bz #435341
Comment 2 Milan Broz 2008-03-25 11:44:06 EDT
Ok, fix from bug 435341 should go to RHEL5.2 too.
I'll use this BZ as clone for adding the patch mentioned in
https://bugzilla.redhat.com/show_bug.cgi?id=435341#c22
Comment 7 errata-xmlrpc 2008-05-21 10:26:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0379.html

Note You need to log in before you can comment on or make changes to this bug.