Bug 437480 - xulrunner package update does not "update"
xulrunner package update does not "update"
Status: CLOSED DUPLICATE of bug 433096
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On: 431162
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 10:22 EDT by Steve Murphy
Modified: 2008-03-14 15:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 15:04:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Murphy 2008-03-14 10:22:40 EDT
Fedora 9 alpha. Firefox won't start (reported).
Package Updater keeps presenting "xulrunner" package. Downloads and installs
without any errors (that I know of). And the updater wants to install it again,
and so on. Maybe 5 iterations now.

Is the update package brain-dead? or is the package update system having a stroke?
Comment 1 Robert Gray 2008-03-14 14:51:44 EDT
Good eye, Steve:

I found the same problem late last night. I can't even raise Firefox or shut 
the system down properly.

As of this morning, my instance has 
2 package update managers (the regular package updater(henceforth called 
Update1) and the new "Update System" pkg mgr(Update2).

The Update(1) calls for 
xulrunner 1.9-0.38cvs20080310.fc9.... 
to replace
xulrunner 1.9Beta2.12nightly20080121.fc9....
and if you allow Update1 to apply it, the mgr appears to make the changes.

However, with this AM's pkg updates, I rcvd Update(2), which also tells me 
that I need to update xulrunner.

Update(2) calls for 
The need to have >= 1.9-0.40.cvs20080312.fc9....
in order for the update to work

We've:

1) A xulrunner package gap
2) 2 GUI Package Updaters (at least in my case - new version, perhaps?) that 
are showing different needs for the same pkg (xulrunner in our case) 


(In reply to comment #0)
> Fedora 9 alpha. Firefox won't start (reported).
> Package Updater keeps presenting "xulrunner" package. Downloads and installs
> without any errors (that I know of). And the updater wants to install it 
again,
> and so on. Maybe 5 iterations now.
> 
> Is the update package brain-dead? or is the package update system having a 
stroke?

Comment 2 Will Woods 2008-03-14 15:04:35 EDT
This was a problem with the xulrunner package in F9a that's since been fixed. It
requires manual intervention to fix, though. Run:

rpm -e --nodeps xulrunner
yum install xulrunner



*** This bug has been marked as a duplicate of 433096 ***

Note You need to log in before you can comment on or make changes to this bug.