Bug 437501 - lets you add LVM component partitions to the grub boot menu
lets you add LVM component partitions to the grub boot menu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
NeedsRetesting
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-14 12:26 EDT by Bill Nottingham
Modified: 2014-03-16 23:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 12:26:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-03-14 12:26:32 EDT
Description of problem:

Seems fishy. Although starting to filter the display there could get you into
more trouble.

Version-Release number of selected component (if applicable):

rawhide-20080314
Comment 1 Jeremy Katz 2008-03-14 18:17:12 EDT
On which screen?  We're just going off of disks as far as I can tell from
looking at the code
Comment 2 Bill Nottingham 2008-03-17 11:29:45 EDT
The 'choose other partitions to boot' widget.
Comment 3 Jeremy Katz 2008-03-17 15:46:44 EDT
Oh, you mean the partitions which are _part_ of a volume, not the volumes
themselves.

We've actually allowed this forever.  But easy enough to filter out LVM (and
RAID) components
Comment 4 Jesse Keating 2008-04-03 15:28:33 EDT
Think this could be done for F9, or should we punt for F10?  Since this has been
allowed before, I don't see it as being an F9 blocker.

The bug is in Modified state, so maybe the fix is already done and we just need
a retest?
Comment 5 Jeremy Katz 2008-04-03 15:37:37 EDT
The definition of the MODIFIED state is "a fix has been committed"
Comment 6 Jon Stanley 2008-04-14 12:26:28 EDT
Tested:

Installing onto single disk.   Several other disks (not used in install) were
previously part of a raidset.  Attempted to add at 'boot loader operating system
list' screen, and the only device presented was /dev/sda1 (as would be expected
- /dev/sda2 is an LVM partition, and the remaining disks are RAID).

Closing

Note You need to log in before you can comment on or make changes to this bug.