Bug 437508 - SELinux is preventing npviewer.bin (nsplugin_t) "read" to ./MSMINCHO.ttf (user_fonts_t).
SELinux is preventing npviewer.bin (nsplugin_t) "read" to ./MSMINCHO.ttf (use...
Status: CLOSED DUPLICATE of bug 250249
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 12:47 EDT by Matěj Cepl
Modified: 2008-04-01 01:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 17:20:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-03-14 12:47:38 EDT
Description of problem:

Summary:

SELinux is preventing npviewer.bin (nsplugin_t) "read" to ./MSMINCHO.ttf
(user_fonts_t).

Detailed Description:

SELinux denied access requested by npviewer.bin. It is not expected that this
access is required by npviewer.bin and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

Sometimes labeling problems can cause SELinux denials. You could try to restore
the default system file context for ./MSMINCHO.ttf,

restorecon -v './MSMINCHO.ttf'

If this does not work, there is currently no automatic way to allow this access.
Instead, you can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                unconfined_u:unconfined_r:nsplugin_t:SystemLow-
                              SystemHigh
Target Context                system_u:object_r:user_fonts_t
Target Objects                ./MSMINCHO.ttf [ file ]
Source                        npviewer.bin
Source Path                   /usr/lib64/nspluginwrapper/npviewer.bin
Port                          <Unknown>
Host                          hubmaier.ceplovi.cz
Source RPM Packages           nspluginwrapper-0.9.91.5-26.fc9
Target RPM Packages           
Policy RPM                    selinux-policy-3.3.1-17.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall_file
Host Name                     hubmaier.ceplovi.cz
Platform                      Linux hubmaier.ceplovi.cz
                              2.6.25-0.113.rc5.git2.fc9 #1 SMP Tue Mar 11
                              22:33:43 EDT 2008 x86_64 x86_64
Alert Count                   1
First Seen                    Fri 14 Mar 2008 17:20:38 CET
Last Seen                     Fri 14 Mar 2008 17:20:38 CET
Local ID                      79e2c3ca-0684-4c48-bf90-6f3774a32750
Line Numbers                  

Raw Audit Messages            

host=hubmaier.ceplovi.cz type=AVC msg=audit(1205511638.632:979): avc:  denied  {
read } for  pid=4712 comm="npviewer.bin" name="MSMINCHO.ttf" dev=dm-0
ino=6340521 scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023
tcontext=system_u:object_r:user_fonts_t:s0 tclass=file

host=hubmaier.ceplovi.cz type=SYSCALL msg=audit(1205511638.632:979):
arch=c000003e syscall=2 success=no exit=-13 a0=23ecad0 a1=0 a2=0 a3=0 items=0
ppid=28609 pid=4712 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500
egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="npviewer.bin"
exe="/usr/lib64/nspluginwrapper/npviewer.bin"
subj=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 key=(null)

Version-Release number of selected component (if applicable):
nspluginwrapper-0.9.91.5-26.fc9.x86_64
selinux-policy-targeted-3.3.1-17.fc9.noarch

Additional Info:
I don't even know, whether we want to fix it, but I think it should be known
that sometimes swfdec-mozilla just doesn't work. It happened to me on
http://news.bbc.co.uk/2/hi/technology/7290322.stm and video seems to work
Comment 1 Matěj Cepl 2008-03-31 17:16:26 EDT
Probably duplicate of bug 439885, but want to keep information available.
Comment 2 Matěj Cepl 2008-03-31 17:20:09 EDT

*** This bug has been marked as a duplicate of 250249 ***
Comment 3 Daniel Walsh 2008-04-01 01:22:41 EDT
Also not a duplicate, will add to 

Fixed in selinux-policy-3.3.27.fc9

Note You need to log in before you can comment on or make changes to this bug.