Bug 437515 - getty started on console too soon
getty started on console too soon
Status: CLOSED DUPLICATE of bug 437379
Product: Fedora
Classification: Fedora
Component: event-compat-sysv (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-03-14 13:20 EDT by Doug Chapman
Modified: 2014-06-18 04:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 13:27:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-03-14 13:20:54 EDT
Description of problem:

It appears the console event is starting at an inapropriate time.  On a normal
boot I see getty starts immediatly after udev.  This isn't really a big issue
(just looks garbled on the console), the getty functions properly once all other
startup scripts run.

However, the bigger issue is when booting single user mode it tries to do both,
it starts getty AND opens a shell on the console.  Screen is garbled and it
appears characters typed randomly go to either the shell or getty (near as I can
tell).  This makes single user mode unusable.

This was on a ia64 with a serial console, I have an x86 system at home running
rawhide with a normal VGA console there, I will see if the same thing happens there.


Version-Release number of selected component (if applicable):
event-compat-sysv-0.3.9-9.fc9
upstart-0.3.9-12.fc9
sysvinit-tools-2.86-24

(I confirmed that the old sysvinit package is _not_ installed).


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2008-03-14 13:27:54 EDT

*** This bug has been marked as a duplicate of 437379 ***

Note You need to log in before you can comment on or make changes to this bug.