Bug 437516 - Net Install: installer adds slashes / if the URL is wrong
Net Install: installer adds slashes / if the URL is wrong
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 13:23 EDT by Dag
Modified: 2008-04-03 10:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 12:23:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag 2008-03-14 13:23:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
When you try to install Fedora from the rescue CD, it asks for the method you want to use.
If you choose "URL" then enter a wrong URL, say "ftp://ftp.free.fr/fedora/os",
it displays the URL entering screen again but it added a slash "/" after the server's name: "ftp://ftp.free.fr//fedora/os"
if you try it again without modifying you get "ftp://ftp.free.fr///fedora/os"

So One slash is added with each erroneous URL entered.
If you correct the URL but let the multiple slashes added, it's working as if there was only one slash, so it's not blocking.

Version-Release number of selected component (if applicable):
Fedora9-Alpha i386 rescue CD

How reproducible:
Always


Steps to Reproduce:
1. boot from Fedora 9 Alpha rescue CD i386
2. choose to install
3. choose the "URL" method
4. enter a wrong URL and validate
5. the URL entering screen is displayed again with a slash added after the server's name

Actual Results:
It adds a slash with each erroneous URL entered.

Expected Results:
It should display the entry as the user typed it, not adding or removing anything.

Additional info:
Those additional slashes seem to be stripped off the URL when validating the entry because even if you add a dozen to a correct URL Anaconda is starting and installation begins.
Comment 1 Chris Lumens 2008-03-19 12:23:42 EDT
This will be fixed in the next build of anaconda.
Comment 2 Dag 2008-04-03 05:58:32 EDT
This bug is still here in the Beta 9, is it "normal" ?
When will the next build of anaconda come ?
Comment 3 Chris Lumens 2008-04-03 10:39:44 EDT
This was fixed in rawhide released after the beta, which is why you don't see it
there.  There have been ten builds of anaconda after the one that was in the
beta, so they come pretty quickly.

Note You need to log in before you can comment on or make changes to this bug.