Bug 437534 - livecd can't find root
livecd can't find root
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Beta F9PR
  Show dependency treegraph
 
Reported: 2008-03-14 15:08 EDT by Bill Nottingham
Modified: 2014-03-16 23:12 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 11:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-03-14 15:08:59 EDT
Description of problem:

Doesn't find the root volume correctly. However, all I need to do is run:

echo "add" > /sys/block/sr0/uevent

and exit the shell, and it's OK.

Version-Release number of selected component (if applicable):

rawhide-20080314 livecd
Comment 1 Bill Nottingham 2008-03-14 15:36:19 EDT
Happens on a i965 ahci box. Doesn't happen on a plain-IDE box using ata_piix. 
Comment 2 Jeremy Katz 2008-03-14 17:53:41 EDT
Hmmm, doesn't happen in kvm for me either which is going to make this a little
trickier to debug :-/

I wonder if we're losing the uevent and if Harald's recent changes to add more
debugging would help track it down
Comment 3 Harald Hoyer 2008-03-14 18:34:15 EDT
I saw this problem on a kvm with a LVM partition as a virtual harddisk...

debugging only helps in start_udev
Comment 4 Bill Nottingham 2008-03-17 11:30:46 EDT
I rebuilt a livecd with some udev debugging, but it was really too much noise to
filter through. So far it fails on one box, but works on another (and in KVM.)
Comment 5 Bill Nottingham 2008-03-18 12:26:09 EDT
So, this appears to be a kernel bug. udev gets the uevent for /dev/sr0, and
attempts to run vol_id on the device:

/dev/.tmp-11-0: error opening volume: No mediun found

I suspect the initial uevent needs to be delayed until the inital medium scan is
done, at least until we can get reliable uevents for medium changes.
Comment 6 Jeremy Katz 2008-03-20 11:33:42 EDT
Reproduced on real hardware.  Yeah, I don't know that we can really do anything
about this in the initrd (well, unless we make all calls to vol_id run sleep
first) or something crazy like that
Comment 7 Carl Worth 2008-04-03 01:10:53 EDT
Bill,

Thanks for the workaround in this bug report.

I just tried booting the F9 Beta Live CD for the first time and the boot halted
with:

WARNING: Cannot find root file system!
Create symlink /dev/root and then exit this shell to continue the boot sequence.

I looked around for an existing bug report, but failed to find any. Luckily
David Zeuthen pointed me to this bug report. At first I thought the workaround
didn't work, but then I found that if I waited for a while between the echo and
the exit that it all worked.

Hopefully my comment here might make the bug report easier for others to find in
searching.

And let me know if it would be useful to get any characterizations from another
actual hardware machine that hits the bug.

-Carl
Comment 8 Jeremy Katz 2008-04-04 12:32:54 EDT
Awful terrible hack for the initrd pushed to git that should work around this
Comment 9 Harald Hoyer 2008-04-05 07:30:25 EDT
maybe fixed with udev-120, because a lot of rules now react on 'change' (dunno,
if the kernel sends an event here)
Comment 10 Jeremy Katz 2008-04-11 10:29:30 EDT
Between new udev and my hack, I was at least able to boot on the box that I
couldn't before.  Bill -- how about on yours?
Comment 11 Bill Nottingham 2008-04-11 11:17:39 EDT
Works with 0411.

Note You need to log in before you can comment on or make changes to this bug.