Bug 437534 - livecd can't find root
Summary: livecd can't find root
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F9Beta F9PR
TreeView+ depends on / blocked
 
Reported: 2008-03-14 19:08 UTC by Bill Nottingham
Modified: 2014-03-17 03:12 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-11 15:17:39 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2008-03-14 19:08:59 UTC
Description of problem:

Doesn't find the root volume correctly. However, all I need to do is run:

echo "add" > /sys/block/sr0/uevent

and exit the shell, and it's OK.

Version-Release number of selected component (if applicable):

rawhide-20080314 livecd

Comment 1 Bill Nottingham 2008-03-14 19:36:19 UTC
Happens on a i965 ahci box. Doesn't happen on a plain-IDE box using ata_piix. 

Comment 2 Jeremy Katz 2008-03-14 21:53:41 UTC
Hmmm, doesn't happen in kvm for me either which is going to make this a little
trickier to debug :-/

I wonder if we're losing the uevent and if Harald's recent changes to add more
debugging would help track it down

Comment 3 Harald Hoyer 2008-03-14 22:34:15 UTC
I saw this problem on a kvm with a LVM partition as a virtual harddisk...

debugging only helps in start_udev

Comment 4 Bill Nottingham 2008-03-17 15:30:46 UTC
I rebuilt a livecd with some udev debugging, but it was really too much noise to
filter through. So far it fails on one box, but works on another (and in KVM.)

Comment 5 Bill Nottingham 2008-03-18 16:26:09 UTC
So, this appears to be a kernel bug. udev gets the uevent for /dev/sr0, and
attempts to run vol_id on the device:

/dev/.tmp-11-0: error opening volume: No mediun found

I suspect the initial uevent needs to be delayed until the inital medium scan is
done, at least until we can get reliable uevents for medium changes.

Comment 6 Jeremy Katz 2008-03-20 15:33:42 UTC
Reproduced on real hardware.  Yeah, I don't know that we can really do anything
about this in the initrd (well, unless we make all calls to vol_id run sleep
first) or something crazy like that

Comment 7 Carl Worth 2008-04-03 05:10:53 UTC
Bill,

Thanks for the workaround in this bug report.

I just tried booting the F9 Beta Live CD for the first time and the boot halted
with:

WARNING: Cannot find root file system!
Create symlink /dev/root and then exit this shell to continue the boot sequence.

I looked around for an existing bug report, but failed to find any. Luckily
David Zeuthen pointed me to this bug report. At first I thought the workaround
didn't work, but then I found that if I waited for a while between the echo and
the exit that it all worked.

Hopefully my comment here might make the bug report easier for others to find in
searching.

And let me know if it would be useful to get any characterizations from another
actual hardware machine that hits the bug.

-Carl


Comment 8 Jeremy Katz 2008-04-04 16:32:54 UTC
Awful terrible hack for the initrd pushed to git that should work around this

Comment 9 Harald Hoyer 2008-04-05 11:30:25 UTC
maybe fixed with udev-120, because a lot of rules now react on 'change' (dunno,
if the kernel sends an event here)

Comment 10 Jeremy Katz 2008-04-11 14:29:30 UTC
Between new udev and my hack, I was at least able to boot on the box that I
couldn't before.  Bill -- how about on yours?

Comment 11 Bill Nottingham 2008-04-11 15:17:39 UTC
Works with 0411.


Note You need to log in before you can comment on or make changes to this bug.