Bug 437542 - Password Updating fields not needed for Pam Authenticated users
Password Updating fields not needed for Pam Authenticated users
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
520
All Linux
medium Severity low
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
https://rlx-2-10.rhndev.redhat.com/rh...
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2008-03-14 16:07 EDT by Partha Aji
Modified: 2014-05-09 06:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 06:38:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Partha Aji 2008-03-14 16:07:51 EDT
Description of problem:
We should not be allowing users to change passwords on user details screen if
pam authentication is turned on for the satellite and users are Pam Enabled..
This is because changing the passwords on this screen only updates the database
making those columns irrelevant..

Version-Release number of selected component (if applicable): 5.1


How reproducible: Always


Steps to Reproduce:
1. Turn On Pam authentication in a satellite server
2. Setup a Pam authentication enabled user in your org.. (so in theory the user
should be able to login with his kerberos username/password)
3. Click on "Your Account"
  
Actual results:
You see text fields that let you change passwords . Changing this password and
clicking update has no impact whatso ever other than changing the info in the
database..,The User would still have to login using kerberos usernam/password.

Expected results:
You either don't want to let them change passwords or post a warning message
saying "changing passwords here won't be helpful unless you ve turned off pam
authentication.."

Additional info:
Comment 2 Paul Morgan 2010-08-27 15:08:04 EDT
I would propose a different "expected results":

1. Pam checkbox should appear below the username field
   but above the password fields. This presents a more
   intuitive order of completing the form.

2. When the pam checkbox is checked, the password fields
   should be disabled, preventing input.

   If user unchecks the pam checkbox, the password fields
   should be enabled and required (as indicated by red asterisk).
Comment 3 Clifford Perry 2014-05-09 06:38:42 EDT
We have not addressed this specific bug in over 5 years years. This does not seem to have an active customer case with the bug report either. Closing out as wontfix to clear from backlog. 

Please re-open if you disagree and wish further review.

Cliff

Note You need to log in before you can comment on or make changes to this bug.