Bug 437569 - Misconfigurations in named.conf configuration template
Misconfigurations in named.conf configuration template
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-14 18:10 EDT by Adrian Offerman
Modified: 2013-04-30 19:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 08:45:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
named.conf configuration template (4.17 KB, text/plain)
2008-03-14 18:10 EDT, Adrian Offerman
no flags Details
improved sample (3.95 KB, text/plain)
2008-03-19 09:04 EDT, Adam Tkac
no flags Details

  None (edit)
Description Adrian Offerman 2008-03-14 18:10:13 EDT
Description of problem:
Misconfigurations in named.conf configuration template

Version-Release number of selected component (if applicable):
Seen with version 9.5.0 on Fedora 7 and 9.3.3 on CentOS 5.1 (so is probably in
other RH Linux versions as well).

How reproducible:

Steps to Reproduce:
1. create a named configuration based on the template named.conf in
/usr/share/doc/bind-9.x.x/sample/etc/named.conf
2. do a query from an outside IP address, e.g. dig @nameserver host.domain

Actual results:
query refused

Expected results:
answer

Additional info:
I think the "match-clients" and "match-destinations" were misunderstood when
creating this template. These are matched against the source and destination
address, respectively, of the query.

They now read:
view "localhost_resolver" {
  match-clients { localhost; };
  match-destinations { localhost; };
  ...
  }
view "internal" {
  match-clients { localnets; };
  match-destinations { localnets; };
  ...
  }
view "external" {
  match-clients { !localnets; !localhost; };
  match-destinations { !localnets; !localhost; };
  ...
  }

Causing a refusal from an external client since there will never be a match.

I think these statements should read (works for me to get this solved):
view "localhost_resolver" {
  match-clients { localhost; };
  match-destinations { localhost; };
  ...
  }
view "internal" {
  match-clients { localnets; };
  match-destinations { localhost; };
  ...
  }
view "external" {
  match-clients { !localnets; !localhost; any; };
  match-destinations { localhost; };
  ...
  }
Comment 1 Adrian Offerman 2008-03-14 18:10:13 EDT
Created attachment 298093 [details]
named.conf configuration template
Comment 2 Adam Tkac 2008-03-19 08:55:43 EDT
You're right, sample is not good. I'm going to attach improved one.
Comment 3 Adam Tkac 2008-03-19 09:04:49 EDT
Created attachment 298501 [details]
improved sample

Improved sample removed some unneded statements (query-port options and
match-destinations) and adds RFC 1912 zones to internal view. "external" view
can match any (look on
http://www.isc.org/sw/bind/arm93/Bv9ARM.ch06.html#view_statement_grammar)
Comment 4 Adam Tkac 2008-04-02 08:45:17 EDT
Improved template is commited into rawhide, will be avaliable in next build
(9.5.0-30.b2.fc9). I'm not going to release this as F7/F8/RHEL update.

Note You need to log in before you can comment on or make changes to this bug.