Bug 437590 - When Shut Down, ~/.gnome2/session file automatically is made.
When Shut Down, ~/.gnome2/session file automatically is made.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-14 20:48 EDT by sangu
Modified: 2008-03-16 00:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-16 00:33:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
~/.gnome2/session file (2.88 KB, text/plain)
2008-03-14 20:48 EDT, sangu
no flags Details

  None (edit)
Description sangu 2008-03-14 20:48:49 EDT
Description of problem:
When Shutdown,  ~/.gnome2/session file automatically is made.

Log Out, Restart -> no problem.

Version-Release number of selected component (if applicable):
2.22.0-1.fc9

How reproducible:
always

Steps to Reproduce:
1.  Click Shut Down on panel
2.
3.
  
Actual results:


Expected results:


Additional info:
gdm-2.21.9-3.fc9.i386
Comment 1 sangu 2008-03-14 20:48:49 EDT
Created attachment 298108 [details]
~/.gnome2/session file
Comment 2 jmccann 2008-03-15 00:13:17 EDT
 manager.c process_save_request() has:
if (!shutdown)
	    save_selected = TRUE;

and then in maybe_write_session():

  if (autosave || save_selected || session_save)
    write_session ()


So it seems like when global save is requested without a shutdown the session is
always saved.  Which doesn't seem right.
Comment 3 Matthias Clasen 2008-03-15 13:53:07 EDT
Looks like the only way to fix this for now is to make the panel look at the
auto-save gconf key itself.

Note You need to log in before you can comment on or make changes to this bug.