Bug 437610 - xulrunner pkg gap and dupe GUI PkgUpdaters - Firefox down
xulrunner pkg gap and dupe GUI PkgUpdaters - Firefox down
Status: CLOSED DUPLICATE of bug 433096
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-15 03:49 EDT by Robert Gray
Modified: 2008-08-02 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 14:19:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Regular Pkg Updater - with the "nightly" xulrunner (304.87 KB, image/png)
2008-03-16 14:02 EDT, Robert Gray
no flags Details
The allegedly "New" System Update with latest (phantom?) xulrunner version (242.12 KB, image/png)
2008-03-16 14:03 EDT, Robert Gray
no flags Details
Here's a scrnshot of xulrunner pkgs listed in Add/Remove Software. What are the consequences of downloading and installing Firefox directly from Mozilla? Will it interfere with Fedora's release? Thanks (43.84 KB, image/png)
2008-03-16 15:53 EDT, Robert Gray
no flags Details

  None (edit)
Description Robert Gray 2008-03-15 03:49:49 EDT
Description of problem:
xulrunner packages appear on two gui package updater, and older package 
repeatedly needs to be installed.


Version-Release number of selected component (if applicable):
1) 1.9-0.38cvs20080310.fc9: Supposedly replaces 1.9beta2.12nightly20080121.fc9 
- shows up repeatedly after application on Older Package Updater

2) 1.9-0.40cvs20080312.fc9: Referenced by another GUI "System Updater as a 
prerequisite (as in >= pkg####) for installation.

I'm unable to raise Firefox as well - IANAGeckoDeveloper; but IIRC, Firefox 
uses XUL.  From the other bugs listed, I presume that the pkg is related to my 
Firefox problem.

How reproducible:
Let the Package Updaters (both of them) run naturally - within a minute of 
loggin in.

Steps to Reproduce:
1. See xulrunner pkgs on both Pkg Updaters
2. update older pkg
3. watch older pkg made avail again
4. repeat loop of hell (option - rebooting won't help)
  
Actual results:

1) Same pkg needs updating
2) Firefox can't be raised.

Thanks
Comment 1 Matthias Clasen 2008-03-15 12:48:34 EDT
Which "package updaters" are you talking about here ?
Comment 2 Robert Gray 2008-03-16 14:02:15 EDT
Created attachment 298200 [details]
Regular Pkg Updater - with the "nightly" xulrunner
Comment 3 Robert Gray 2008-03-16 14:03:20 EDT
Created attachment 298201 [details]
The allegedly "New" System Update with latest (phantom?) xulrunner version
Comment 4 Robert Gray 2008-03-16 14:14:30 EDT
Greetings, Matthew:

Neither update takes hold - all I get is an endless loop asking to install the 
same updates all over again.

I get the same results for the Yum on Terminal and for Yum Extender GUI (both 
for the latest xulrunner) as well.

this is what I have installed thus far:
rpm -q xulrunner
xulrunner-1.9-0.beta2.12.nightly20080121.fc9.i386

rpm -q firefox
firefox-3.0-0.40.cvs20080312.fc9.i386
Comment 5 Robert Gray 2008-03-16 15:53:41 EDT
Created attachment 298214 [details]
Here's a scrnshot of xulrunner pkgs listed in Add/Remove Software.

What are the consequences of downloading and installing Firefox directly from Mozilla?

Will it interfere with Fedora's release?  

Thanks
Comment 6 Matěj Cepl 2008-03-17 11:51:35 EDT
I am afraid that this is dupe of bug xulrunner-cpio. What happens when you
remove the old xulrunner and then reinstall?
Comment 7 Matěj Cepl 2008-03-17 11:52:41 EDT
sorry, hyperlinking doesn't work that well -- bug 433096 is what I meant.
Comment 8 Christopher Aillon 2008-03-17 14:19:58 EDT
Definitely a dupe.  That's the last version before the cpio thing happened.

Only way to fix it is for you to do rpm -e -nodeps xulrunner && yum install
xulrunner

*** This bug has been marked as a duplicate of 433096 ***
Comment 9 Robert Gray 2008-03-17 18:42:06 EDT
Thanks, Gents:

I tried the -e option over the weekend.  The --nodeps and reinstall worked.

Regards 

Note You need to log in before you can comment on or make changes to this bug.