Bug 437632 - Enhancement request: "whoami" extended operation
Enhancement request: "whoami" extended operation
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.1.2
All Linux
high Severity low
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks: 389_1.3.0 512820 690319
  Show dependency treegraph
 
Reported: 2008-03-15 11:24 EDT by Andrey Ivanov
Modified: 2015-01-04 18:31 EST (History)
3 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.2.0-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 14:36:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrey Ivanov 2008-03-15 11:24:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Description of problem:
The directory server should support the "Who am I?" extended operation (OID 1.3.6.1.4.1.4203.1.11.3) described in RFC4532.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
ldapwhoami -x -h ldap-server.example.com

Actual Results:
Result: Protocol error (2)
Additional info: unsupported extended operation

Expected Results:
shoud suport this extended operation

Additional info:
This is an enhancement request, not a bug.
Comment 1 Rich Megginson 2009-04-09 13:14:19 EDT
This falls under the category of RFC correctness
Comment 3 Martin Kosek 2012-01-04 08:45:15 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/123
Comment 4 Nathan Kinder 2013-12-18 14:36:45 EST
This was fixed in 389-ds-base-1.3.2.0-1.fc20.

Note You need to log in before you can comment on or make changes to this bug.