Bug 437669 - Unhandled exception (in vgcreate or thereabouts)
Unhandled exception (in vgcreate or thereabouts)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-15 21:42 EDT by Pierre Lewis
Modified: 2008-07-02 20:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 20:55:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt + anaconda.log (31.60 KB, application/octet-stream)
2008-03-15 21:42 EDT, Pierre Lewis
no flags Details

  None (edit)
Description Pierre Lewis 2008-03-15 21:42:36 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Try installing to HDD again (I've tried this three times now)


Steps to Reproduce:
1.Start installer from live CD
2.Specify configuration
3.Launch installer
  
Actual results:
unhandled exception after 15+ minutes. Significant messages:
/dev/sda5: read failed after 0 of 2048 at 0: Input/output error
...
Unable to add physical volume '/dev/sda5' to volume group 'VolGroup00'.

Expected results:
A working Linux system...

Additional info:

Summary: trying to install to free space on HDD, anaconda gets an
   unhandled exception after 15+ minutes. Significant messages:
   /dev/sda5: read failed after 0 of 2048 at 0: Input/output error
   ...
   Unable to add physical volume '/dev/sda5' to volume group 'VolGroup00'.

Here briefly what I tried.

Machine in five lines:
- Alienware Area-51 7500 R5 PC: 2 GB RAB, Intel Core duo E4500 @ 2.2 GHz,
  NVIDIA GeForce 8800 GT (512 MB).
- NVIDIA nForce 680i SLI Motherboard
- Disk: ST325041 0AS SCSI Disk Device.
  - 206.09 GB NTFS (C:)
  - 19.53 GB (unallocated, size of C: reduced from within Vista)
  - 7.26 GB RAW (E:)
- Vista Home Premium, 32-bit OS (which I want to keep!).
- Bios: Phoenix - AwardBIOS v6.00PG,  version: ALWARE - 42302e31

Fdisk reports:
   Disk /dev/sda: 250.0 GB, 250059350016 bytes
   255 heads, 63 sectors/track, 30401 cylinders
   Units = cylinders of 16065 * 512 = 8225280 bytes
   Disk identifier: 0x7a591861

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       26904   216101537    7  HPFS/NTFS
/dev/sda2           29454       30401     7611392    7  HPFS/NTFS

Using Fedora-8-Live-x86_64 live DVD downloaded a few weeks ago.
No USB or firewire devices attached. The live CD works fine for
everything I tried.

Double-clicked installer, with following choices:
- Use free space on disk (the 19 GB), review layout
- In VG00, removed the swap partition (pretty useless with 2G RAM)
- So the setup looked like this:
  sda
    sda1  ntfs     211037 MB  (Vista C:)
    (free)              5 MB
    sda3  /boot       196 MB  format checkmark
    sda4  extended  19799 MB
      sda5 VG00     19799 MB  format checkmark
    (free)              3 MB
    sda2  ntfs       7433 MB  (Vista E:)
- Selected no GRUB (I want to use NeoGRUB from Vista)
- Selected eth2

Started the install at 7:46 PM
No progress in progress bar

Ten minutes later, ctrl-atl-F1, ps -aux shows one task started
at 7:46, /live/udev/vol_d --export /dev/.tmp-8-5

A bit later, at 20:02, I see a new task, lvm vgscan -v

A bit later, at 20:04, I see a new task, lvm vgcreate ...
 
Then back on ctrl-atl-F7, I see the exception attached. The main
problem seems to be (from lvmout):

   /dev/sda5: read failed after 0 of 2048 at 0: Input/output error
     Wiping cache of LVM-capable devices
   /dev/sda5: read failed after 0 of 2048 at 0: Input/output error
   /dev/sda5: read failed after 0 of 2048 at 0: Input/output error
   No physical volume label read from /dev/sda5
   /dev/sda5 not identified as an existing physical volume
   Unable to add physical volume '/dev/sda5' to volume group 'VolGroup00'.

As a side note, on rebooting Vista, the system is verry slow. Cleaning
up the new partitions fixes things (as I learned in an earlier attempt).
Comment 1 Pierre Lewis 2008-03-15 21:42:36 EDT
Created attachment 298171 [details]
anacdump.txt + anaconda.log
Comment 2 Pierre Lewis 2008-03-15 21:45:51 EDT
OUPS, forgot to put a DESCRIPTION:

Trying to install to free space on HDD, anaconda gets an
   unhandled exception after 15+ minutes. Significant messages:
   /dev/sda5: read failed after 0 of 2048 at 0: Input/output error
   ...
   Unable to add physical volume '/dev/sda5' to volume group 'VolGroup00'.   
Comment 3 Jeremy Katz 2008-03-16 13:10:46 EDT
There are read errors from your drive here.  Are you sure your hard drive isn't
failing?
Comment 4 Pierre Lewis 2008-03-16 17:34:18 EDT
Well, that HDD works fine with Vista, has never given trouble. Yes it does
suggest drive problems, but not plain failure, rather some kind of
incompatibility. I've browsed the web, but haven't found a conclusive answer.
Linux does have drivers for SATA, but is the chipset I have supported? Maybe
that's the root problem. 

The anaconda unhandled exception asked me to open a bug report, perhaps that
will get me closer to an answer...

Side question. I was surprised that 15+ minutes into the install, we were just
beginning to do lvm vgcreate. What happened before?
Comment 5 Andy Lindeberg 2008-06-04 10:03:15 EDT
Have you encountered the same problem with Fedora 9?
Comment 6 Pierre Lewis 2008-06-05 08:51:53 EDT
I have not tried with Fedora 9. 

I haven't read anything in the release notes that suggests this problem might
have been fixed, and there hasn't been much action on this bug. 

Do you think it is worth a try? 
Comment 7 Andy Lindeberg 2008-06-05 09:53:07 EDT
It probably is worth a try, at the very least so we know if it's still happening
or if it got fixed (either deliberately or incidentally).

Since there are read issues, it could also be a problem with your harddrive.
Comment 8 Pierre Lewis 2008-07-02 20:54:46 EDT
Well, notwithstanding my doubts, it was a disk problem. Two months after the
above attempts, the HDD died in Vista, and refused to let Vista be re-installed.
I finally got a replacement drive, and installing Fedora 9 on it was a breeze.
So I guess that closes this ticket. I suspect the disk problems were in the area
where Linux tried to install, whereas Vista was at the bottom of the disk, far
away from the trouble area. But eventually, the disease spread...

Note You need to log in before you can comment on or make changes to this bug.