Bug 437672 - 1000Hz timer still active on tickless kernel
Summary: 1000Hz timer still active on tickless kernel
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-16 02:47 UTC by Michael Cronenworth
Modified: 2008-03-16 03:23 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2008-03-16 03:23:22 UTC


Attachments (Terms of Use)
dmesg.txt (28.18 KB, text/plain)
2008-03-16 02:47 UTC, Michael Cronenworth
no flags Details
lspci.txt (26.04 KB, text/plain)
2008-03-16 02:48 UTC, Michael Cronenworth
no flags Details
powertop.txt (792 bytes, text/plain)
2008-03-16 02:50 UTC, Michael Cronenworth
no flags Details

Description Michael Cronenworth 2008-03-16 02:47:35 UTC
Description of problem: Powertop reports that a 1000Hz timer is still active.
This prevents the CPU from sleeping.


Version-Release number of selected component (if applicable): kernel-2.6.24.3-12.fc8


How reproducible: Always


Steps to Reproduce:
1. Boot Kernel
2. Sit at idle
  
Actual results: ~1600 wakeups


Expected results: ~500 or lower wakeups


Additional info: Attaching lspci, dmesg, and powertop outputs.

This does not happen on my Pentium 4 3ghz HT-enabled 32-bit machine. Same
packages installed.

Comment 1 Michael Cronenworth 2008-03-16 02:47:35 UTC
Created attachment 298174 [details]
dmesg.txt

Comment 2 Michael Cronenworth 2008-03-16 02:48:01 UTC
Created attachment 298175 [details]
lspci.txt

Comment 3 Michael Cronenworth 2008-03-16 02:50:53 UTC
Created attachment 298176 [details]
powertop.txt

Comment 4 Dave Jones 2008-03-16 03:23:22 UTC
it's because of the IR receiver on your TV card.  AFAICT, this is a limitation
of the hardware (it doesn't appear to send an interrupt when it receives an IR
event, so the kernel has to poll frequently to see if something happened).  If
we lower the polling frequency, we may end up missing events.



Note You need to log in before you can comment on or make changes to this bug.