Bug 4377 - ftp install fails, incorrectly reports ftp server cannot be set to passive
ftp install fails, incorrectly reports ftp server cannot be set to passive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-05 14:17 EDT by behl
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-25 08:51:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description behl 1999-08-05 14:17:57 EDT
Trying to do a network install from a ftp fails when the
install program believes (incorrectly) it cannot set the
server to passive.  Snooping the attempt and looking at the
ftp server logs shows that the server did go to passive
mode, but the install program incorrectly handled a
multi-line successfull login message/greeting.
According to RFC 959, a multi-line responsponse to a command
is signified by a 3 digit response code AND a hyphen (in the
case of a successful password/login, it is "230-".  The
final line should be the same response code WITHOUT a hypen
(just a "230 ").  All intermediate lines can be plain text
without any prepended response code.
Doing a snoop and looking over the ftp server log files
shows the Redhat install client successfully logging into
the server.  The first line of the login message is sent
with the "230-" prepended (signifying a multi-line text
response is to follow).  Howerver, after receiving the
second line of text (normal text without any 3 digit code),
the client immediately issues the "go to passive" command.
The server continues sending the remainder of the greeting
message, at which time the install client, not
immediately seeing a successful response to its "go to
passive" command, interprets the server as unable to go to
passive and fails.  It should be noted that the server does
correctly end the greeting message with a text line
prepended with "230 " (no hypen) and then responds with a
'now in passive mode' reply to the clients earlier request.
A work around for this was to prepend every line of our
login greering with a "230-" and the final lines with "230
".  This, howerver, should not be necessary.
Jeff
Comment 1 mbrennen 2000-02-02 17:40:59 EST
FYI: this is happening on the 5.2 and 6.0 Alpha installations, even if there is
no multiline login banner.  I can see when logging in with the old ftp command
line client that a single "230 ...." message is returned, and both distros are
failing with the "failed to set the server in passive mode' message.

I'm trying 5.2 and 6.0 because 6.1 is broken and will not install on my Alpha.
The bug has already been reported and assigned.
Comment 2 Derek Tattersall 2000-04-25 08:51:59 EDT
Can't duplicate this bug using the 6.2 installer.

Note You need to log in before you can comment on or make changes to this bug.