Bug 437723 - LVM too restrictive - if first/only OS in drive, consumes entire drive
LVM too restrictive - if first/only OS in drive, consumes entire drive
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-16 19:11 EDT by Robert Gray
Modified: 2008-04-08 08:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 08:23:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GParted Profile of HDD - LVM shrunk due to RAID Partitions (now deleted) (40.74 KB, image/png)
2008-03-16 19:11 EDT, Robert Gray
no flags Details

  None (edit)
Description Robert Gray 2008-03-16 19:11:01 EDT
Since I couldn't find a "feature enhancement request", I'm posting one here - 
thanks.

Description of problem:

FC9's LVM setup appears to be too restrictive. When installed in an empty 
drive, LVM takes up the entire drive, or the final portion of the HD, which 
makes it difficult to make partitions for other Operating Systems.

Note - per FedoraForum, there's an abundant number of people (including yours 
truly) having difficulty resizing / dealing with LVM.

I made an interim solution by making 2 Sofware RAID Partitions; and was able to 
liberate a portion of my HDD; but the "/" and LVM partitions are separated by 
that "gap".

I'd like to use the 2 Remaining Partitions to install another OS/Distro or two.

I submitted a call-for-help in FedoraForums for a workaround; but since this is 
a Feature request, I've attached present GParted Profile and fdisk dialog  
below:

# fdisk -l

Disk /dev/sda: 41.1 GB, 41174138880 bytes
255 heads, 63 sectors/track, 5005 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x03220322

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        5004    40194598+   7  HPFS/NTFS

Disk /dev/sdb: 100.2 GB, 100256292864 bytes
255 heads, 63 sectors/track, 12188 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x11a34bcc

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          25      200781   83  Linux
/dev/sdb4            7956       12188    34001572+   5  Extended
/dev/sdb5            7956       12188    34001541   8e  Linux LVM

Disk /dev/dm-0: 34.8 GB, 34817049600 bytes
255 heads, 63 sectors/track, 4232 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 32.6 GB, 32614907904 bytes
255 heads, 63 sectors/track, 3965 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-1 doesn't contain a valid partition table

Disk /dev/dm-2: 2080 MB, 2080374784 bytes
255 heads, 63 sectors/track, 252 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x30307800

If you need anything else, pls let me know - thanks.
Comment 1 Robert Gray 2008-03-16 19:11:01 EDT
Created attachment 298224 [details]
GParted Profile of HDD - LVM shrunk due to RAID Partitions (now deleted)
Comment 2 Milan Broz 2008-04-08 06:42:43 EDT
Reassigning to anaconda - installer is responsible here.
Comment 3 Jeremy Katz 2008-04-08 08:23:50 EDT
If you customize your partition layout, you can leave as much space as you want.
 Our defaults are to use the remaining free space that you have available.

Note You need to log in before you can comment on or make changes to this bug.