Bug 437724 - handler not found noise in log on startup
Summary: handler not found noise in log on startup
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcdbd (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-16 23:31 UTC by Tim Burke
Modified: 2013-04-12 19:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 08:54:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dhcdbd-2.2-log-debug.patch (26.13 KB, patch)
2008-07-17 01:12 UTC, David Cantrell
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0646 normal SHIPPED_LIVE dhcdbd bug fix update 2008-09-03 08:54:08 UTC

Description Tim Burke 2008-03-16 23:31:56 UTC
On Mar 15, 2008, at 6:51 AM, Tim Burke wrote:

> Just installed 5.2 beta... and see a bunch of "handler not found" in syslog. 
Is this expected?
>
>
> -------------------------------------------------------
> Mar 15 10:42:53 localhost dhclient: DHCPACK from 192.168.1.1
> Mar 15 10:42:53 localhost NetworkManager: <information> DHCP daemon state is
now 2 (bound) for interface eth0
> Mar 15 10:42:53 localhost NetworkManager: <information> Activation (eth0)
Stage 4 of 5 (IP Configure Get) scheduled...
> Mar 15 10:42:53 localhost NetworkManager: <information> Activation (eth0)
Stage 4 of 5 (IP Configure Get) started...
> Mar 15 10:42:53 localhost dhclient: bound to 192.168.1.104 -- renewal in 37293
seconds.
> Mar 15 10:42:53 localhost dhcdbd: message_handler: message handler not found
under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.host_name
> Mar 15 10:42:53 localhost dhcdbd: message_handler: message handler not found
under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.domain_name
> Mar 15 10:42:53 localhost dhcdbd: message_handler: message handler not found
under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.nis_domain
> Mar 15 10:42:53 localhost dhcdbd: message_handler: message handler not found
under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.nis_servers
> Mar 15 10:42:53 localhost NetworkManager: <information> Retrieved the
following IP4 configuration from the DHCP daemon:

Those messages have been present since 5.0.  I'm seeing them on both 5.0 and 5.1
test systems I have here.

dhcdbd should probably only output that at the DEBUG log level.  Can fix that in
5.3, I guess.

-- 
David Cantrell <dcantrell@redhat.com>
Red Hat / Honolulu, HI

Comment 1 James Laska 2008-05-30 12:02:11 UTC
Any particular setup conditions required to trigger these messages?  Or just a
straightforward local ipv6 address configuration?

Comment 2 David Cantrell 2008-05-30 20:17:54 UTC
I think just a normal install will report those messages.

Comment 3 David Cantrell 2008-07-17 01:12:33 UTC
Created attachment 312006 [details]
dhcdbd-2.2-log-debug.patch

Comment 7 Chris Ward 2008-08-22 17:13:05 UTC
David, could you please give me some more details about how to reproduce this bug? System config? The more the merrier. Thanks!

Comment 8 David Cantrell 2008-08-22 19:57:07 UTC
(In reply to comment #7)
> David, could you please give me some more details about how to reproduce this
> bug? System config? The more the merrier. Thanks!

dhcdbd is run as a service at boot time.  It's required by NetworkManager.  If you have a system set up that's using NetworkManager, that's all you need.  dhcdbd will start up at boot time.

There's nothing to do to reproduce this problem except to monitor the syslog.  With the update, the messages noted in Tim's description should no longer appear.

Comment 11 errata-xmlrpc 2008-09-03 08:54:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0646.html


Note You need to log in before you can comment on or make changes to this bug.