Bug 437727 - PulseAudio starts without problems, no sound is played
PulseAudio starts without problems, no sound is played
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-16 20:39 EDT by Flóki Pálsson
Modified: 2009-01-07 13:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 08:28:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
statuns on pulseaudio (2.04 KB, text/plain)
2008-03-16 20:39 EDT, Flóki Pálsson
no flags Details
output from terminal (4.71 KB, text/plain)
2008-03-17 15:06 EDT, Flóki Pálsson
no flags Details
Pulse.log (297.70 KB, text/plain)
2008-03-17 15:07 EDT, Flóki Pálsson
no flags Details
log fron soundcard test (245 bytes, text/plain)
2008-03-17 17:07 EDT, Flóki Pálsson
no flags Details
log from souncard test (48.38 KB, text/plain)
2008-03-17 17:07 EDT, Flóki Pálsson
no flags Details
output from pulseaudio -vvv step 3 (5.80 KB, text/plain)
2008-03-18 05:00 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2008-03-16 20:39:26 EDT
Description of problem:


Version-Release number of selected component (if applicable):
pulseaudio-0.9.8-5.fc8
kernel-2.6.24.3-12.fc8

How reproducible:
install Fc8 clean - update all 


Steps to Reproduce:
1.
play sound  Rhythmbox Music Player Manual V2.0.2
2.
3.
  
Actual results:
No sound

Expected results:
sound in headphones 

Additional info:
Comment 1 Flóki Pálsson 2008-03-16 20:39:26 EDT
Created attachment 298227 [details]
statuns on pulseaudio
Comment 2 Lubomir Kundrak 2008-03-17 02:29:19 EDT
Would "rm -rf /tmp/pulse-*" and loggin out help?
Comment 3 Flóki Pálsson 2008-03-17 05:53:30 EDT
No.
After logout, login 
no pulseauidio process is running
no music in headphones  

No change in sound  if pulseauidio is manualy  started.
But in rythminbox the progressbars dos not move
Comment 4 Flóki Pálsson 2008-03-17 06:11:18 EDT
No change after latest updates 
kernel-2.6.24.3-34.fc8
Comment 5 Lubomir Kundrak 2008-03-17 06:37:06 EDT
So please paste the output of following:

(as root)
# rm -rf /tmp/pulse-*
(as ordinary user)
$ strace -o pulse.log pulseaudio -vvv

and please attach pulse.log
Comment 6 Flóki Pálsson 2008-03-17 15:06:23 EDT
Created attachment 298294 [details]
output from terminal
Comment 7 Flóki Pálsson 2008-03-17 15:07:07 EDT
Created attachment 298295 [details]
Pulse.log
Comment 8 Lubomir Kundrak 2008-03-17 16:36:51 EDT
bind(23, {sa_family=AF_FILE, path="/tmp/.esd-500/socket"}, 22) = -1 EADDRINUSE
(Address already in use)
ioctl(2, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
write(2, "E: socket-server.c: \33[1;31mbind("..., 62) = 62

Please paste the output of
# /sbin/fuser -v /tmp/.esd-500/socket

Seems like something is occupying the esd socket.
This is not the first time I see it, but I don't remember what was the cause before.

Thanks
Comment 9 Flóki Pálsson 2008-03-17 17:07:10 EDT
Created attachment 298307 [details]
log fron soundcard test
Comment 10 Flóki Pálsson 2008-03-17 17:07:55 EDT
Created attachment 298308 [details]
log from souncard test
Comment 11 Flóki Pálsson 2008-03-17 17:12:41 EDT
[floki@dhcppc2 ~]$ /sbin/fuser -v /tmp/.esd-500/socket
[floki@dhcppc2 ~]$ 

[floki@dhcppc2 ~]$ su -
Password: 
[root@dhcppc2 ~]# [floki@dhcppc2 ~]$ /sbin/fuser -v /tmp/.esd-500/socket
-bash: [floki@dhcppc2: command not found
[root@dhcppc2 ~]# [floki@dhcppc2 ~]$ 
-bash: [floki@dhcppc2: command not found
[root@dhcppc2 ~]# 

Comment 12 Flóki Pálsson 2008-03-17 17:16:59 EDT
Sorry 
[root@dhcppc2 ~]# /sbin/fuser -v /tmp/.esd-500/socket
                     USER        PID ACCESS COMMAND
/tmp/.esd-500/socket:
                     floki      2971 f.... pulseaudio
[root@dhcppc2 ~]# 
Comment 13 Lubomir Kundrak 2008-03-18 04:32:45 EDT
This means pulseaudio is actually running! I am wondering what would happen if
you killed it and tried to start it again. So a few more directions:

1.) Kill the running pulseaudio with either
# kill 2971
or maybe
# pkill -KILL pulseaudio

2.) Just to make sure we won't hit another known bug, please remove the
pulseaudio temporary directory (try as root)
# rm -rf /tmp/pulse-floki

3.) Now, as non-root user, try to launch pulseaudio with verbose output:
$ pulseaudio -vvv

4.) Open another console, see if you can play sounds now:
$ paplay /usr/share/sounds/startup3.wav
This should play via pulseaudio
$ pasuspender /usr/bin/aplay -- -D hw:0 /usr/share/sounds/startup3.wav
This should play sound directly via ALSA

I am interested in output of pulseaudio -vvv started in 3.); please attach it.
Comment 14 Flóki Pálsson 2008-03-18 05:00:49 EDT
Created attachment 298347 [details]
output from pulseaudio -vvv step 3
Comment 15 Flóki Pálsson 2008-03-18 05:05:55 EDT
1.
[floki@dhcppc2 ~]$ pkill -KILL pulseaudio
[floki@dhcppc2 ~]$ 
ok checked in system monitor


2.
[root@dhcppc2 ~]# rm -rf /tmp/pulse-floki 
[root@dhcppc2 ~]# 


3.
[floki@dhcppc2 ~]$ pulseaudio -vvv
W: polkit.c: Failed ...
se Created an attachment (id=298347) 

4.
in new terminal window
[floki@dhcppc2 ~]$ paplay /usr/share/sounds/startup3.wav
[floki@dhcppc2 ~]$ 
No sound 
Comment 16 Lubomir Kundrak 2008-03-18 06:47:26 EDT
(In reply to comment #13)
> $ pasuspender /usr/bin/aplay -- -D hw:0 /usr/share/sounds/startup3.wav
> This should play sound directly via ALSA

Try this. Thanks.

I do not see any problem with PulseAudio.
Comment 17 Flóki Pálsson 2008-03-18 14:36:02 EDT
[floki@dhcppc2 ~]$ pasuspender /usr/bin/aplay -- -D hw:0
/usr/share/sounds/startup3.wav
Playing WAVE '/usr/share/sounds/startup3.wav' : Signed 16 bit Little Endian,
Rate 44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)
         please, try the plug plugin 
[floki@dhcppc2 ~]$ 
Comment 18 Lubomir Kundrak 2008-03-18 14:49:31 EDT
Did you hear the sound play?
Comment 19 Flóki Pálsson 2008-03-18 15:10:12 EDT
no
Comment 20 Lubomir Kundrak 2008-03-18 15:56:25 EDT
I'm wondering if this would be any different:

$ pasuspender /usr/bin/aplay -- -D plughw:0 /usr/share/sounds/startup3.wav
Comment 21 Flóki Pálsson 2008-03-18 16:47:44 EDT
sorry 
I have reinstalld fc8.
I was using worng pluginn.
I can hear sound now after chancing too diffrent pluginn for headphones.
I am now going to update fc8.
Comment 22 Flóki Pálsson 2008-03-18 21:05:31 EDT
Now FC8 reinstalled an updated
Sound is ok

After manual activating eth0.bak ( kown bug ) I have to logout and login
to hear sound. 

1.
[floki@dhcppc2 ~]$ pasuspender /usr/bin/aplay -- -D plughw:0
/usr/share/sounds/startup3.wav
Playing WAVE '/usr/share/sounds/startup3.wav' : Signed 16 bit Little Endian,
Rate 44100 Hz, Stereo
[floki@dhcppc2 ~]$ 
I hear sound
2.
[floki@dhcppc2 ~]$ pasuspender /usr/bin/aplay -- -D hw:0
/usr/share/sounds/startup3.wav
Playing WAVE '/usr/share/sounds/startup3.wav' : Signed 16 bit Little Endian,
Rate 44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)
         please, try the plug plugin 
[floki@dhcppc2 ~]$ 

I hear sound 

Comment 23 Flóki Pálsson 2008-03-18 21:26:00 EDT
"After manual activating eth0.bak ( kown bug ) I have to logout and login
to hear sound. "
Not wright

But after manual activating  eth0.bak after booting
then response from PulseAudio is 
"Connection failed: Connection refused"
But sound is ok


Comment 24 Lubomir Kundrak 2008-03-19 08:28:00 EDT
(In reply to comment #23)
> "After manual activating eth0.bak ( kown bug ) I have to logout and login
> to hear sound. "
> Not wright

This can not have influenced Pulseaudio, you don't play sound through network.

> But after manual activating  eth0.bak after booting
> then response from PulseAudio is 
> "Connection failed: Connection refused"
> But sound is ok

I'm closing this bug as you head the sound play.

Look here to see if you can fix something yourself, should more issues arise,
and eventually open another bug report:

http://fedoraproject.org/wiki/LubomirKundrak/SoundTroubleshooting

Note You need to log in before you can comment on or make changes to this bug.