Bug 437737 - conky 1.4.9 needs patch for apci changes in 2.6.24 kernel
conky 1.4.9 needs patch for apci changes in 2.6.24 kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: conky (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Michael Rice
Fedora Extras Quality Assurance
http://sourceforge.net/mailarchive/fo...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 01:17 EDT by Don Seiler
Modified: 2008-04-16 23:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.5.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 23:51:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Seiler 2008-03-17 01:17:54 EDT
Description of problem:
See
http://sourceforge.net/mailarchive/forum.php?thread_name=20080209113243.GB13561%40imsc.res.in&forum_name=conky-development

Per that mailing list thread, conky 1.4.9 can no longer read apci/battery
information since they moved with 2.6.24 kernels.  The developer has provided a
patch, no ETA on when the next release might be.  Fedora should include this
patch in its conky package since it is using the 2.6.24 kernel.

Version-Release number of selected component (if applicable):
1.4.9

How reproducible:
100%


Steps to Reproduce:
1. Install fedora with 2.6.24 kernel (current in repos is 2.6.24.3-34.fc8)
2. Install conky 1.4.9 (which is current in repos)
3. Launch conky with any of the battery variables in the .conkyrc
  
Actual results:
No battery information is provided.  battery returns nothing, battery_bar is
empty, battery_percent is 0.

Expected results:
Accurately reflect battery status in various variables.
Comment 1 Fedora Update System 2008-03-23 08:23:01 EDT
conky-1.5.0-1.fc8 has been submitted as an update for Fedora 8
Comment 2 Don Seiler 2008-03-23 11:03:35 EDT
Ah I see he cut a new release.  That'll do just as well then.  Thanks!
Comment 3 Fedora Update System 2008-03-26 13:17:49 EDT
conky-1.5.0-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update conky'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2732
Comment 4 Fedora Update System 2008-04-01 07:07:53 EDT
conky-1.5.1-1.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-04-16 23:51:55 EDT
conky-1.5.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.