Bug 437764 - openoffice.org does not show the "ی" character correctly
openoffice.org does not show the "ی" character correctly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 06:58 EDT by Adrin Jalali
Modified: 2008-03-26 06:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 06:49:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture (1.75 KB, image/png)
2008-03-17 15:23 EDT, Caolan McNamara
no flags Details
the wrong form. (1.95 KB, image/jpeg)
2008-03-19 16:41 EDT, Adrin Jalali
no flags Details
right form of the character (1.23 KB, image/jpeg)
2008-03-19 16:45 EDT, Adrin Jalali
no flags Details
fc-list output (13.60 KB, text/plain)
2008-03-19 16:48 EDT, Adrin Jalali
no flags Details
sample document + used fonts (306.12 KB, application/octet-stream)
2008-03-25 09:29 EDT, Adrin Jalali
no flags Details
document (7.92 KB, application/vnd.oasis.opendocument.text)
2008-03-26 05:38 EDT, Caolan McNamara
no flags Details
OOo screenshot (12.54 KB, image/png)
2008-03-26 05:39 EDT, Caolan McNamara
no flags Details
gedit screenshot (17.66 KB, image/png)
2008-03-26 05:39 EDT, Caolan McNamara
no flags Details
firefox screenshot (7.73 KB, image/png)
2008-03-26 05:40 EDT, Caolan McNamara
no flags Details
looks ok for me (12.06 KB, image/png)
2008-03-26 06:12 EDT, Caolan McNamara
no flags Details

  None (edit)
Description Adrin Jalali 2008-03-17 06:58:12 EDT
Description of problem:
I'm using openoffice-2.3.0-6.11.fc8 and I've installed msttcorefonts package.
When I set my font to Tahoma, the "ی" character does not transform to small type
and always is shown as capital letter, when I type sime text in openoffice, and
then paste it to some html file and show in in firefox, that is shown correctly.

Best,
adrin.
Comment 1 Adrin Jalali 2008-03-17 06:58:56 EDT
By the way, I'm using Iran/Pro keyboard layout.
Comment 2 Caolan McNamara 2008-03-17 15:23:49 EDT
Created attachment 298298 [details]
picture

Here's a picture without tamoha installed, so before I get tamoha, is the above
picture correct ?
Comment 3 Caolan McNamara 2008-03-18 06:36:27 EDT
I have the same results after install mscorefonts, so can you attach a picture
of what's the wrong result in OOo, and perhaps attach the output of fc-list and
the output of rpm -qa | grep fonts.

If there is a problem here I suspect it might not be with Tamaho at all but with
some other font
Comment 4 Adrin Jalali 2008-03-19 16:41:14 EDT
Created attachment 298586 [details]
the wrong form.

this is the wrong form I see in openoffice. the right form is attached next.
Comment 5 Adrin Jalali 2008-03-19 16:45:21 EDT
Created attachment 298588 [details]
right form of the character

this is the right form of the character which is seen in firefox. (see the
right character) someone says that this is because firefox and oowriter decide
in different ways about using capital case or small case of characters.
Comment 6 Adrin Jalali 2008-03-19 16:48:53 EDT
Created attachment 298589 [details]
fc-list output

fc-list output is attached and more :
$ rpm -qa | grep fonts
baekmuk-ttf-fonts-common-2.2-6.fc8
lohit-fonts-hindi-2.1.9-1.fc8
bitmap-fonts-0.3-5.1.2.fc7
sazanami-fonts-gothic-0.20040629-4.20061016.fc8
lohit-fonts-oriya-2.1.9-1.fc8
xorg-x11-fonts-Type1-7.2-3.fc8
liberation-fonts-1.0-1.fc8
lohit-fonts-gujarati-2.1.9-1.fc8
xorg-x11-fonts-misc-7.2-3.fc8
lohit-fonts-tamil-2.1.9-1.fc8
lohit-fonts-kannada-2.1.9-1.fc8
kacst-fonts-1.6.2-2.fc8
ghostscript-fonts-5.50-18.fc8
lohit-fonts-punjabi-2.1.9-1.fc8
paktype-fonts-2.0-2.fc8
jomolhari-fonts-0.003-4.fc8
xorg-x11-fonts-ISO8859-1-100dpi-7.2-3.fc8
lohit-fonts-malayalam-2.1.9-1.fc8
lohit-fonts-bengali-2.1.9-1.fc8
baekmuk-ttf-fonts-gulim-2.2-6.fc8
lklug-fonts-0.2.2-5.fc8
xorg-x11-fonts-truetype-7.2-3.fc8
msttcorefonts-1.2-3
dejavu-lgc-fonts-2.19-1
xorg-x11-fonts-100dpi-7.2-3.fc8
urw-fonts-2.4-3.fc8
dejavu-fonts-2.20-1.fc8
tetex-fonts-3.0-44.8.fc8
lohit-fonts-telugu-2.1.9-1.fc8
cjkunifonts-uming-0.1.20060928-4.fc8


Best.
Adrin.
Comment 7 Caolan McNamara 2008-03-25 08:22:37 EDT
Still not able to reproduce this, though I installed mscorefonts and then tried
to get as many fonts as were not from a specific rpm but were listed in the
output above. 

I sort of suspect that there's an alternative substitution being given to OOo
which firefox doesn't get, e.g. because OOo only uses outline fonts, and that
the font is simply busted, and the same thing would be seen in all apps if they
also rejected non-outline fonts. But I can't get it to happen for me to identify
what font is truly in use here.
Comment 8 Adrin Jalali 2008-03-25 09:29:55 EDT
Created attachment 299018 [details]
sample document + used fonts

here is a sample document in which I used the tahoma font and arial font, and I
attached these two fonts too.

Thanks for your attention.
Best,
adrin.
Comment 9 Caolan McNamara 2008-03-26 05:38:54 EDT
Created attachment 299109 [details]
document
Comment 10 Caolan McNamara 2008-03-26 05:39:25 EDT
Created attachment 299110 [details]
OOo screenshot
Comment 11 Caolan McNamara 2008-03-26 05:39:57 EDT
Created attachment 299111 [details]
gedit screenshot
Comment 12 Caolan McNamara 2008-03-26 05:40:31 EDT
Created attachment 299112 [details]
firefox screenshot
Comment 13 Caolan McNamara 2008-03-26 05:46:23 EDT
Your sample document contained the characters 06CC *followed by* 06A9, i.e.
"ARABIC LETTER FARSI YEH" and then "ARABIC LETTER KEHEH", not just 06CC (ی)
"ARABIC LETTER FARSI YEH" on its own. 

If I place each character separately, or place them side by side to combine then
I get the same results in OOo, firefox and gedit with Arial.

In comment #9 I attach a sample openoffice.org document that has the 06CC on its
own, 06A9 on its own, and then both together to show the difference. It all
looks ok to me, and all the apps here that I have appear to agree as to how to
render it.
Comment 14 Adrin Jalali 2008-03-26 05:59:36 EDT
Yeah it's ok while I use arial font, the problem is with tahoma font. just
change the font to tahoma, in your own document, the ARABIC LETTER FARSI YEH
will be shown in a different manner when it's beside ARABIC LETTER KEHEH.
Comment 15 Caolan McNamara 2008-03-26 06:12:56 EDT
Created attachment 299121 [details]
looks ok for me
Comment 16 Caolan McNamara 2008-03-26 06:14:14 EDT
Seeing as Tahoma does not have these glyphs, then there has to be a fallback in
operation, and its hard to figure how what's being used for the glyph fallback.
My own fallbacks appears to be working fine
Comment 17 Adrin Jalali 2008-03-26 06:49:10 EDT
I decided to change my tahoma font copied from another computer, it is fixed
now. Maybe if you use my attached tahoma font in tar.gz archive, you will see
what's wrong. But I think that's because my tahoma font was not standard. Who
knows ;)

I think I can change the status.

Best,
adrin.

Note You need to log in before you can comment on or make changes to this bug.