Bug 437765 - After install of F8 respin firstboot wizard isn't started
After install of F8 respin firstboot wizard isn't started
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 06:59 EDT by Valent Turkovic
Modified: 2008-03-26 13:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.1.1.1-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 13:11:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
this is what users see after first boot of fedora 8 live cd with updated packages (139.91 KB, image/png)
2008-03-17 11:24 EDT, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2008-03-17 06:59:11 EDT
Description of problem:
Hi,
our local LUG organized Fedora/Ubuntu install fest and I created for
that occasion respin of Fedora 8 Live CD with updated packages because
I didn't want to have 10 people go and try to get 200MB (or is it even
more) of updates all at once.

I recreated the Fedora 8 Live CD with this command:
livecd-creator -c livecd-fedora-8-desktop.ks -f F8Desktop -t /virtual/tmp

It boots and it installs to hard disk without problems, but after
first boot there is no "first boot wizard" that creates user so all
users get is an empty gdm screen to which then can it they know enter
root as a user.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Valent Turkovic 2008-03-17 10:11:14 EDT
# /usr/sbin/firstboot
 File "/usr/sbin/firstboot", line 101, in <module>
   firstbootWindow(fb)
 File "/usr/share/firstboot/firstbootWindow.py", line 150, in __init__
   self.loadModules()
 File "/usr/share/firstboot/firstbootWindow.py", line 426, in loadModules
   loaded = imputil.imp.load_module(module, found[0], found[1], found[2])
 File "/usr/share/firstboot/modules/smolt.py", line 10, in <module>
   from firstboot.config import *
Comment 2 Jeroen van Meeuwen 2008-03-17 10:14:48 EDT
Changing component to smolt as judging from the traceback it is triggering an
ImportError by tryinig to import * from firstboot.config
Comment 3 Valent Turkovic 2008-03-17 11:24:38 EDT
Created attachment 298273 [details]
this is what users see after first boot of fedora 8 live cd with updated packages
Comment 4 Mike McGrath 2008-03-17 20:22:12 EDT
This is because I foolishly updated the F9 smolt-firstboot in F8.  F9 and F8
firstboot don't play nice.  I"ll get this fixed tonight.
Comment 5 Fedora Update System 2008-03-18 09:34:56 EDT
smolt-1.1.1.1-2.fc8 has been submitted as an update for Fedora 8
Comment 6 Valent Turkovic 2008-03-20 03:52:29 EDT
I guess I was too fast, because I made a new F8 CD respin but
smolt-1.1.1.1-1.fc8 is still the latest version :(

I'll try again in a couple of days.
Comment 7 Mike McGrath 2008-03-20 09:45:25 EDT
This is in testing waiting for someone to test, I'm in training all week and my
quick look at 1.1.1.1 on my laptop with an updated firstboot on F8 yielded no
problems.

https://admin.fedoraproject.org/updates/F8/pending/smolt-1.1.1.1-2.fc8

http://koji.fedoraproject.org/koji/buildinfo?buildID=43127

If it gets the thumbs up from someone I'll push it to stable.  Otherwise it will
have to wait until monday or tuesday.
Comment 8 Luis Felipe Marzagao 2008-03-20 23:27:11 EDT
Just tried with smolt-1.1.1.1-2.fc8, but no success:

[root@localhost ~]#  firstboot 
no image found
  File "/usr/sbin/firstboot", line 101, in <module>
    firstbootWindow(fb)
  File "/usr/share/firstboot/firstbootWindow.py", line 150, in __init__
    self.loadModules()
  File "/usr/share/firstboot/firstbootWindow.py", line 426, in loadModules
    loaded = imputil.imp.load_module(module, found[0], found[1], found[2])
Comment 9 Valent Turkovic 2008-03-21 12:33:27 EDT
I have F8 with:
firstboot - 1.4.39-1.fc8
smolt - 1.1.1.1-1.fc8

and I get this:

[root@localhost ~]# /usr/sbin/firstboot
firstboot cannot run, exiting
Comment 10 Fedora Update System 2008-03-21 18:04:44 EDT
smolt-1.1.1.1-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smolt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2563
Comment 11 Mike McGrath 2008-03-22 18:08:19 EDT
(In reply to comment #9)
> I have F8 with:
> firstboot - 1.4.39-1.fc8
> smolt - 1.1.1.1-1.fc8
> 
> and I get this:
> 
> [root@localhost ~]# /usr/sbin/firstboot
> firstboot cannot run, exiting


Make sure you rm -f /etc/sysconfig/firstboot

Also I believe this package will help:

http://koji.fedoraproject.org/koji/buildinfo?buildID=43553
Comment 12 Fedora Update System 2008-03-22 18:09:40 EDT
smolt-1.1.1.1-3.fc8 has been submitted as an update for Fedora 8
Comment 13 Luis Felipe Marzagao 2008-03-22 23:21:32 EDT
Release 3 did the trick! 

https://admin.fedoraproject.org/updates/F8/pending/smolt-1.1.1.1-3.fc8

Thanks.
Comment 14 Mike McGrath 2008-03-22 23:24:51 EDT
Excellent, sorry it took so long, I was a bit careless in -2.   It should be
pushed soon.
Comment 15 Fedora Update System 2008-03-26 13:11:29 EDT
smolt-1.1.1.1-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.