Bug 437769 - Useless error messages about ldap server not reachable on udev-start
Useless error messages about ldap server not reachable on udev-start
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 07:29 EDT by Christof Kaelin
Modified: 2013-03-05 22:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 05:03:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christof Kaelin 2008-03-17 07:29:30 EDT
Description of problem:
Since hal update 0.5.10-1 I get the following messages (about 100 times) on
starting udev service fc8 on all my machines. I suspect hal, because udev has
not been updated since 21st Jan.

udevd[54]: nss_ldap: could not search LDAP server - Server is unavailable
and then 6 times:
vol_id[762]: nss_ldap: could not search LDAP server - Server is unavailable

My machine has nss_ldap, authentication and automount enabled (although i don't
think it has to do with automount). This error does not make any sense, as there
is no network available when udev ist starting.

hal 0.5.10-1.fc8.2
udev-118-1.fc8

How reproducible:
Boot into Runlevel 1,2,3,4,5 with nss_ldap and ldapauth enabled.

Steps to Reproduce:
1. Enable ldap-authentication with system-config-authentication
2. (Enable automount through ldap)
3. Reboot and watch messages upon udev start (1st service after initrd-loading)
  
Actual results:
many useless error messages.

Expected results:
just start udev without trying to reach the network for ldap access, which is
not possible, as the network is not started yet.
Comment 1 Christof Kaelin 2008-03-17 13:03:22 EDT
Additional info: Also when the system is up (init 5), nss_ldap (via dbus) is
cluttering my /var/log/messages with these messages nonstop (network stopped).
It's becoming a very annoying bug.
Comment 2 Christof Kaelin 2008-03-17 16:36:30 EDT
It has been solved for me on all machines by "system-config-authentication"
(disable and enable again NSS lookups via ldap).
Comment 3 Christof Kaelin 2008-11-10 05:03:48 EST
Never seen this messages again since F9 (I suppose) => closing this one

Note You need to log in before you can comment on or make changes to this bug.