Bug 437773 - Performing http installation method prompts to enable networking when adding iSCSI volume
Performing http installation method prompts to enable networking when adding ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: David Cantrell
Brock Organ
: Regression
: 439846 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 08:10 EDT by James Laska
Modified: 2013-09-02 02:24 EDT (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:33:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-files.tgz (7.76 KB, application/octet-stream)
2008-03-17 08:21 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-03-17 08:10:07 EDT
Description of problem:

When performing a method=http://.. VNC installation, anaconda prompts for
networking details when selecting to add an iSCSI volume

Version-Release number of selected component (if applicable):

RHEL5.2-Server-20080313.0 (anaconda-11.1.2.107-1.ppc)

How reproducible:
100%


Steps to Reproduce:
1. Boot with "lang=en keymap=us ksdevice=link ip=dhcp
method=http://porkchop.redhat.com/rel-eng/RHEL5.2-Server-20080313.0/5/ppc/os vnc"
2. At apartitioning, select "Advanced Storage Configuration"
  
Actual results:
 - prompted to enable networking
 - clicking "cancel" on network dialog takes me to the expected "Advanced
Storage options" dialog

Expected results:
 - the "Advanced Storage options" dialog


Additional info:
 - The "network" prompt only appears once, if I click cancel, and retry, it will
not appear.  Some flag?
Comment 1 James Laska 2008-03-17 08:20:06 EDT
 - This appears to block adding an iSCSI volume while in text-mode, since the
the text-mode prompt states to boot with "linux asknetwork" to enable networking.
Comment 2 James Laska 2008-03-17 08:21:39 EDT
Created attachment 298260 [details]
anaconda-files.tgz

> tar -ztvf Desktop/anaconda-files.tgz 
-rw-r--r-- root/0	 16221 2008-03-17 08:03 tmp/anaconda.log
-rw-r--r-- root/0	 12915 2008-03-17 08:02 tmp/syslog
-rw-r--r-- root/0	   121 2008-03-17 08:04 tmp/cmdline
-rwxr-xr-x root/0	  1200 2008-03-17 08:01 tmp/vncserver.log
-rw-r--r-- root/0	    98 2008-03-17 07:58 tmp/scsidisks
-rw-r--r-- root/0	    52 2008-03-17 07:58 tmp/modprobe.conf
Comment 3 James Laska 2008-03-27 14:36:32 EDT
Adding Regression keyword since this is a change in behavior from 5.1 and 5.0
and on further inspection appears to prevent the user from manually adding an
iSCSI device altogether.

To recreate:

1) Boot installer by any means using a network installation source (method=http://)
2) at disk prompt, select "Advanced Storage Configuration"
3) a networking dialog appears (it shouldn't), click OK 

Actual results:
 - no network dialog should appear if networking is already configured

Expected result:
 - no network dialog (it's already setup)
Comment 6 David Cantrell 2008-03-31 17:52:38 EDT
The problem here is with an incorrect nl_object_put() call in nl_ip2str() in nl.c.  What I do is first look up 
the index number of the interface you specified.  For example, on my test system, eth1 is interface 
index 4 in netlink-world.  Once I have that, I gather all address objects and iterate over them matching 
the interface index number.  When I find an address type of AF_INET or AF_INET6, I store it for the 
caller.

The loop was broken because I had nl_object_put() at the end, so when the next loop iteration went to 
run, nl_cache_get_next() returned nothing because I had gotten rid of my current object.  You have to 
pass the current object to nl_cache_get_next() to get the next one.  Here's the fix:

diff --git a/isys/nl.c b/isys/nl.c
index 13b1beb..e7bd60c 100644
--- a/isys/nl.c
+++ b/isys/nl.c
@@ -160,8 +160,6 @@ char *nl_ip2str(char *ifname) {
                 }
             }
         }
-
-        nl_object_put(obj);
     } while ((obj = nl_cache_get_next(obj)) != NULL);
 
 ip2str_error:

This problem is reproduceable on all platforms.  Giving it a devel-ack.
Comment 9 David Cantrell 2008-04-01 16:43:34 EDT
Patch committed to anaconda git repository, will be included in the anaconda-11.1.2.111-1 build.
Comment 10 David Cantrell 2008-04-01 22:57:29 EDT
*** Bug 439846 has been marked as a duplicate of this bug. ***
Comment 12 Brock Organ 2008-04-07 11:58:43 EDT
verified fix in RHEL5.2-Server-20080402.0 for s390x ...
Comment 13 Issue Tracker 2008-04-14 09:28:02 EDT
Update to issue 171202 by bugzilla
> Action: These changes made by borgan@redhat.com.
> Bugzilla comment added:
>  verified fix in RHEL5.2-Server-20080402.0 for s390x ...
> 
> 
> Bugzilla status changed from 'ON_QA' to 'VERIFIED'
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=437773 

The "networking dialog" doesn't appear anymore, but after installing,
it
fails
to boot from the iscsi-disk, we use RHEL5.2 snapshot4:

.....
-----------------------------------------------------
Linux version 2.6.18-88.el5 (brewbuilder@js20-bc2-12.build.redhat.com)
(gcc
version 4.1.2 20071124 (Red Hat 4.1.2-41)) #1 SMP Tue Apr 1 19:06:25 EDT
2008
[boot]0012 Setup Arch
EEH: PCI Enhanced I/O Error Handling Enabled
PPC64 nvram contains 15360 bytes
[boot]0015 Setup Done
Built 1 zonelists.  Total pages: 122880
Kernel command line: root=/dev/VolGroup01/LogVol00 ro console=hvc0 rhgb
quiet
scan-log-dump not implemented on this system
Red Hat nash version 5.1.19.6 starting
iscsistart: transport class version 2.0-724. iscsid version 2.0-868
iscsistart: version 2.0-868
iscsistart: cannot make a connection to 10.100.0.140:3260 (101)
iscsistart: initiator reported error (4 - encountered connection failure)
  Reading all physical volumes.  This may take a while...
  Found volume group "VolGroup00" using metadata type lvm2
  Volume group "VolGroup01" not found
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!
 ehea: Error in ehea_treat_poll_error: CQE Error for QP 16 


This event sent from IssueTracker by jkachuck 
 issue 171202
Comment 14 Issue Tracker 2008-04-14 09:28:04 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ACCEPTED                    |REOPENED
         Resolution|FIX_BY_DISTRO               |




------- Additional Comments From hanpt@cn.ibm.com  2008-04-10 21:53 EDT
-------
System hangs after installing with Snapshot4. Will reopen this bug. Please
see
comment #31 for more messages. 


This event sent from IssueTracker by jkachuck 
 issue 171202
Comment 18 errata-xmlrpc 2008-05-21 11:33:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html

Note You need to log in before you can comment on or make changes to this bug.