Bug 437797 - Spell checking does not work
Spell checking does not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libsexy (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 10:24 EDT by Sindre Pedersen Bjørdal
Modified: 2008-03-25 21:11 EDT (History)
0 users

See Also:
Fixed In Version: 0.1.11-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 21:11:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sindre Pedersen Bjørdal 2008-03-17 10:24:56 EDT
Description of problem:
Spell checking in 0.18-10 running in rawhide does not work. No words are spell
checked in the input field. 

Trying to configure spell checking in preferences allows you to turn it on and
off via the enabled checkbox, but configuring which languages to spell check in
causes spell checking to be simply disabled. No changes here makes spell
checking work however. 

Version-Release number of selected component (if applicable):
0.18-10

How reproducible:
Every time

Steps to Reproduce:
1. Open xchat-gnome, turn spell checking on
2. Enter a word spelled wrongly
3. See, no spell checking!
  
Actual results:
No spell checking

Expected results:
Spell checking should work for the languages configured, configuring languages
for spell checking should work.
Comment 1 Brian Pepple 2008-03-18 20:08:26 EDT
Confirmed that spell-checking is broken, but I'm not 100% sure it's a bug in
xchat-gnome.  Looking into this very briefly, I'm thinking it's due to the
recent changes in enchant, but I need to verify that.

Regardless, this is a pretty low priority right now, and I probably won't have a
chance to look into this until after F9 has hit the streets.
Comment 2 Brian Pepple 2008-03-24 21:00:37 EDT
ok, this bug should be filed against libsexy.  the aspell backend for enchant
was split out from the main enchant package in January, and libsexy only
requires enchant.  So to fix this, libsexy needs to be update to require
enchant-aspell.
Comment 3 Caolan McNamara 2008-03-25 04:40:49 EDT
Hmm, are you *sure* that you need to require enchant-aspell and not just enchant
? i.e. http://fedoraproject.org/wiki/Releases/FeatureDictionary where
enchant by default uses hunspell as the default backend, and the default GNOME
and KDE spellcheckers are using just hunspell via enchant and OOo & firefox use
enchant directly. 

I have xchat-2.8.4-14.fc9.i386 installed here, and no aspell and my spell
checking (english) works out of the box with xchat + enchant and no aspell +
hunspell-en.

Perhaps you want to ensure that e.g. the english dictionaries for hunspell are
required ? e.g. hunspell-en
Comment 4 Kevin Kofler 2008-03-25 10:05:20 EDT
+1 to Caolan's comment, enchant-aspell is entirely the wrong thing to require, 
we don't want dependencies on aspell, hunspell should be used instead!

Note You need to log in before you can comment on or make changes to this bug.