Bug 437812 - RFE: Include compiz-fusion and supporting packages by default
RFE: Include compiz-fusion and supporting packages by default
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: compiz-fusion (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
: FutureFeature, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 11:22 EDT by Valent Turkovic
Modified: 2013-06-29 04:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 04:25:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2008-03-17 11:22:23 EDT
Description of problem:
Currently when you click on "Enable Desktop Effects" compiz starts and replacez
metacity as a window manager.
Compiz compared to Compiz-Fusion lacks a lot of features and plugins for better
usability and more bling.

Please replace compiz with compiz-fusion so that people who want desktop effects
get something more than just rotating cube and wobbly windows.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jesse Keating 2008-03-17 11:47:31 EDT
Uh, we're using compiz-fusion in Fedora.  Compiz is the base level, -fusion adds
some more plugins, and -fusion-extras is even more plugins.
Comment 2 Valent Turkovic 2008-03-18 05:30:10 EDT
I run "yum install compiz-fusion" under F8 live and under F9 beta (current
rawhide) and I see that compiz-fusion isn't installed.

What I meant is that compiz-fusion would be nice to have installed and
configured so that it JustWorks(tm) if somebody wants to enable it.

Currently it is not trivial to enable compiz fusion and configure it to work.

First step in making it JustWork is to have it installed by default and properly
configured.

I understand that Fedora isn't going to enable it by default but there are lots
of issues that are unresolved because small amount of people test compiz-fusion
under fedora.
Comment 3 Valent Turkovic 2008-03-18 05:44:10 EDT
bugs like this one:
https://bugzilla.redhat.com/show_bug.cgi?id=437935
Comment 4 Adel Gadllah 2008-03-18 05:46:23 EDT
compiz cannot be replaced with copiz-fusion because compiz-fusion only provides
additional plugins for compiz and therefore requires compiz!, see  comment 1.
Compiz itself comes with a some plugins that are enabled and installed by
default. If you want additional plugins you will have to install the
compiz-fusion and the compiz-fusion-extras packages. After installation they are
not enabled by default, you will have to enable them using gconf. Unfortunately
the config tools like ccsm do not work with the default configuration (gconf)
but require that its own configuration plugin is used. 
This should be fixed upstream once the object-framework branch is merged.
Comment 5 Adel Gadllah 2008-03-18 05:47:21 EDT
(In reply to comment #3)
> bugs like this one:
> https://bugzilla.redhat.com/show_bug.cgi?id=437935

I don't see how this bug is related to this one.
Comment 6 Valent Turkovic 2008-03-18 05:52:37 EDT
by my understanding here is what you need to install in order to have
compiz-fusion fully installed (it is 5.3 M):

yum install compiz-fusion compiz-fusion-extras emerald-themes emerald
compiz-manager compiz-fusion-extras-gnome gnome-compiz-manager libcompizconfig
compiz-fusion-gnome ccsm
Comment 7 Valent Turkovic 2008-03-18 05:55:47 EDT
I made a confusion by RFE title and if I could I would change it to:

"Install additional plugins via compiz-fusion by default"

we need to have a more functional compiz in fedora by default for testing,
finding bugs, and some time in future to have it enabled by default.
Comment 8 Valent Turkovic 2008-03-18 05:57:57 EDT
(In reply to comment #5)
> (In reply to comment #3)
> > bugs like this one:
> > https://bugzilla.redhat.com/show_bug.cgi?id=437935
> 
> I don't see how this bug is related to this one.

Just as an example to how many more bugs there could be found/reported/fixed it
there was more testing done with compiz.
Comment 9 Valent Turkovic 2008-03-18 06:12:00 EDT
Just to correct my comment #6

to install compiz-fusion with all addons you need only 3.4 M:

yum install compiz-fusion compiz-fusion-extras compiz-fusion-gnome
compiz-fusion-extras-gnome libcompizconfig ccsm compiz-manager fusion-icon-gtk

emerald + themes are another 1.7 M
Comment 10 Adel Gadllah 2008-03-23 11:48:12 EDT
(In reply to comment #9)
> Just to correct my comment #6
> 
> to install compiz-fusion with all addons you need only 3.4 M:
> 
> yum install compiz-fusion compiz-fusion-extras compiz-fusion-gnome
> compiz-fusion-extras-gnome libcompizconfig ccsm compiz-manager fusion-icon-gtk
> 
> emerald + themes are another 1.7 M

You are talking about package size here, not about the size of the installed
packages. There is no point in pulling all this stuff in if its not enabled by
default. And "finding bugs" is not really an argument you can say this for every
package, people that are interessed can install the needed packages from the repo. 
With PackageKit in F9 we now have an easyier to use GUI to do this.
Comment 11 Valent Turkovic 2008-03-24 17:55:14 EDT
(In reply to comment #10)
> (In reply to comment #9)
> > Just to correct my comment #6
> > 
> > to install compiz-fusion with all addons you need only 3.4 M:
> > 
> > yum install compiz-fusion compiz-fusion-extras compiz-fusion-gnome
> > compiz-fusion-extras-gnome libcompizconfig ccsm compiz-manager fusion-icon-gtk
> > 
> > emerald + themes are another 1.7 M
> 
> You are talking about package size here, not about the size of the installed
> packages. There is no point in pulling all this stuff in if its not enabled by
> default. And "finding bugs" is not really an argument you can say this for every
> package, people that are interessed can install the needed packages from the
repo. 
> With PackageKit in F9 we now have an easyier to use GUI to do this.
> 

If we would follow your logic and not mine for installing compiz-fusion and
other dependencies for them why is compiz installed on fedora if it is not
turned on by default? Should we remove compiz because of that from Fedora DVD
and Live CD?
Comment 12 Jon Stanley 2008-04-23 16:29:49 EDT
Adding FutureFeature keyword to RFE's.
Comment 13 Valent Turkovic 2010-05-06 11:33:35 EDT
Any chance of this happening? It has passed a long time since last comments...
Comment 14 Jan Pazdziora 2011-12-31 17:01:13 EST
What exactly is compiz lacking that compiz-fusion provides? I'm using Fedora 16 with Classic GNOME with Compiz and it works just fine.

Note You need to log in before you can comment on or make changes to this bug.