Bug 437823 - traceback when install pv xen
traceback when install pv xen
Status: CLOSED DUPLICATE of bug 426266
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Devan Goodwin
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 11:54 EDT by Miroslav Suchý
Modified: 2009-03-23 22:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 09:47:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch fix this issue. (580 bytes, patch)
2008-03-17 11:56 EDT, Miroslav Suchý
no flags Details | Diff

  None (edit)
Description Miroslav Suchý 2008-03-17 11:54:10 EDT
Description of problem:
see steps to reproduce

Version-Release number of selected component (if applicable):
5.0.1

How reproducible:
three times in row

Steps to Reproduce:
1. 5.0.1 satellite with rhel5 and vt channel
2. rhel5 server with some xen created manualy
3. register server to satellite
4. create new rhel5 pv xen quest on that server
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheRequest.py", line 108, in call_function
    response = apply(func, params)
  File "/usr/share/rhn/server/handlers/xmlrpc/queue.py", line 272, in get
    ret = self.__getV2(action)
  File "/usr/share/rhn/server/handlers/xmlrpc/queue.py", line 86, in __getV2
    xmlblob = xmlrpclib.dumps(result, methodname=action['method'])
  File "/usr/lib/python2.3/xmlrpclib.py", line 961, in dumps
    data = m.dumps(params)
  File "/usr/lib/python2.3/xmlrpclib.py", line 604, in dumps
    dump(v, write)
  File "/usr/lib/python2.3/xmlrpclib.py", line 616, in __dump
    f(self, value, write)
  File "/usr/lib/python2.3/xmlrpclib.py", line 620, in dump_nil
    raise TypeError, "cannot marshal None unless allow_none is enabled"
TypeError: cannot marshal None unless allow_none is enabled

Expected results:
get actions and proceed.

Additional info:
Comment 1 Miroslav Suchý 2008-03-17 11:56:12 EDT
Created attachment 298277 [details]
This patch fix this issue.
Comment 3 Devan Goodwin 2009-02-13 09:47:10 EST

*** This bug has been marked as a duplicate of bug 426266 ***

Note You need to log in before you can comment on or make changes to this bug.