Bug 437846 - Incorrect path to install_initd in scriptlets
Summary: Incorrect path to install_initd in scriptlets
Status: CLOSED DUPLICATE of bug 375361
Alias: None
Product: Fedora
Classification: Fedora
Component: tor (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Enrico Scholz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-17 18:36 UTC by David Walluck
Modified: 2008-03-17 19:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 19:38:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Walluck 2008-03-17 18:36:47 UTC
The tor-lsb package calls

postinstall scriptlet (using /bin/sh):
/usr/lib/lsb/install_initd /etc/rc.d/init.d/tor
preuninstall scriptlet (using /bin/sh):
test "$1" != 0 || /usr/lib/lsb/remove_initd /etc/rc.d/init.d/tor

This is the case even on x86-64 where it should use /usr/lib64. The package
should be using %{_libdir}/lsb/install_initd instead.

Comment 1 Enrico Scholz 2008-03-17 19:38:47 UTC

*** This bug has been marked as a duplicate of 375361 ***

Comment 2 David Walluck 2008-03-17 19:47:15 UTC
Sorry, I didn't see that bug (presumably because it wasn't filed against the tor
package).



Note You need to log in before you can comment on or make changes to this bug.