Bug 437858 - LiveUSB Anaconda Crashes with encrypted /dev/md0
LiveUSB Anaconda Crashes with encrypted /dev/md0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 15:15 EDT by Warren Togami
Modified: 2008-04-23 11:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 16:33:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OSError: [Errno 2] No such file or directory: '/dev/mapper/luks-md0' (22.96 KB, text/plain)
2008-03-17 15:15 EDT, Warren Togami
no flags Details
KeyError: 'crypt_LUKS' (25.55 KB, text/plain)
2008-03-17 15:18 EDT, Warren Togami
no flags Details
make sure root device is set up before trying to use it in a live install (482 bytes, patch)
2008-03-20 15:47 EDT, David Lehman
no flags Details | Diff
setup the device and account for the full path returned by setupDevice (585 bytes, patch)
2008-03-20 16:27 EDT, David Lehman
no flags Details | Diff
anaconda.log (31.87 KB, text/plain)
2008-03-20 16:35 EDT, Warren Togami
no flags Details

  None (edit)
Description Warren Togami 2008-03-17 15:15:33 EDT
1) rawhide live 20080317 attempted "Install to Disk" with weird layout:
/dev/sda1 30GB software RAID
/dev/sda2 30GB software RAID
/dev/sda3 256MB /boot
/dev/sda4 swap
/dev/md0 encrypted RAID1 with /dev/sda1 and /dev/sda2.
Comment 1 Warren Togami 2008-03-17 15:15:33 EDT
Created attachment 298296 [details]
OSError: [Errno 2] No such file or directory: '/dev/mapper/luks-md0'
Comment 2 Warren Togami 2008-03-17 15:18:20 EDT
Created attachment 298297 [details]
KeyError: 'crypt_LUKS'

Rebooting into the same LiveUSB, anaconda crashes earlier when it sees the now
existing encrypted /dev/md0 from the previous attempt.
Comment 3 Warren Togami 2008-03-17 15:19:02 EDT
anaconda-11.4.0.53-1.x86_64
Comment 4 Warren Togami 2008-03-17 15:46:18 EDT
The first crash happens in F9 Alpha LiveUSB, but not the second crash.
Comment 5 Warren Togami 2008-03-20 13:04:55 EDT
This is still broken in F9 Beta LiveUSB.  But interestingly, this type of
install works fine from a non-live anaconda install.
Comment 6 David Lehman 2008-03-20 15:47:06 EDT
Created attachment 298739 [details]
make sure root device is set up before trying to use it in a live install

This is completely untested. Looks like at least a big step in the right
direction based on a quick look at the code.
Comment 7 David Lehman 2008-03-20 16:27:40 EDT
Created attachment 298744 [details]
setup the device and account for the full path returned by setupDevice
Comment 8 Warren Togami 2008-03-20 16:35:05 EDT
Created attachment 298746 [details]
anaconda.log

Got past the crash in Comment #1 with your one-liner patch.  But it crashed a
bit later.  Here is the anaconda.log from that crash.
Comment 9 David Lehman 2008-03-20 19:13:30 EDT
Fix (path from comment #7) will be in anaconda-11.4.0.56-1.
Comment 10 David Lehman 2008-04-18 16:33:29 EDT
My understanding is that this bug was fixed in anaconda-11.4.0.56-1.

Please reopen if that is not the case.

Note You need to log in before you can comment on or make changes to this bug.