Bug 437859 - /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi{,/auto} are not owned
Summary: /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi{,/auto} are not owned
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-17 19:15 UTC by Robert Scheck
Modified: 2008-03-18 13:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 13:51:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2008-03-17 19:15:44 UTC
Description of problem:
The directories /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/auto 
and /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi aren't owned by any 
package, but it should be owned by the perl package.

Version-Release number of selected component (if applicable):
perl-5.10.0-15

How reproducible:
rpm -qf /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi
rpm -qf /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/auto

Actual results:
/usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi{,/auto} aren't owned 
by any package but packages such as perl-DBI and perl-Socket6 are putting some
content inside of them.

Expected results:
Owned directories like before 5.10.0 and as it normally should be.

Comment 1 Marcela Mašláňová 2008-03-18 13:25:39 UTC
I found more directories without owner. Should I add all of them into specfile
or remove them as in postinst as remainder of 5.8.8?
For example:
/usr/lib/perl5/5.8.8
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/
and there will be other.

I force reinstall of perl-5.8.8 on perl-5.10. Maybe that's also part of problem?

Comment 2 Tom "spot" Callaway 2008-03-18 13:31:10 UTC
Nothing should depend on 5.8.8 in rawhide, anything that does needs to be rebuilt.

These directories should not be owned by the rawhide perl package.

Comment 3 Marcela Mašláňová 2008-03-18 13:41:23 UTC
Ok I add to paths only this path:
/usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/auto I think we need
it owned by perl, because some modules are installed into it.

Comment 4 Tom "spot" Callaway 2008-03-18 13:51:56 UTC
Needs a little more than that, we need to handle the other multilib cases, but
I've done that in rawhide now.


Note You need to log in before you can comment on or make changes to this bug.