Bug 437886 - hal-info update required to make Acer TravelMate 230 to suspend again
hal-info update required to make Acer TravelMate 230 to suspend again
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 17:37 EDT by Michal Jaegermann
Modified: 2013-03-05 22:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 10:51:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-03-17 17:37:22 EDT
Description of problem:

An update to Fedora 8 thorougly broke previously working suspend
and hibernate on an Acer TravelMate 230 laptop.  It turned out that
in order to restore functionality a replacement for a file
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi
is needed.

A recent version which can be found at
http://gitweb.freedesktop.org/?p=hal-info.git;a=blob;f=fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi
does include an entry for that laptop.  Not "perfect" though.
After loading it and restarting hal 'lshal | grep quirk' still comes
empty.  That is caused by a spurious blank on a corresponding "match"
line which has

  prefix_outof="TravelMate 630;TravelMate 230 "

With this line replaced with

  prefix_outof="TravelMate 630;TravelMate 230"

and hal restarted that shows up:

  power_management.quirk.s3_bios = true  (bool)
  power_management.quirk.s3_mode = true  (bool)

and the laptop in question start to suspend, hibernate and
(most important) recover from that again.

Version-Release number of selected component (if applicable):
hal-info-20071030-1.fc8

How reproducible:
always

Additional info:
In a replacement file there is another line with what it likes a spurious
blank.  That one:

     <match key="system.hardware.product" contains_outof="1640;3100;5500Z ">

Those finding were sent to hal@lists.freedesktop.org. I do not know
if one can find something similar in other makers fdi files from
the same source.

There are more differences in "old" and "new" 20-video-quirk-pm-acer.fdi
than just a TravelMate 230 entry.
Comment 1 Richard Hughes 2008-05-30 07:52:30 EDT
Does this fix still need applying using F9? if so, please email the hal
development mailing list and we'll review your quirk there. Thanks.
Comment 2 Michal Jaegermann 2008-05-30 13:11:43 EDT
A check of a corresponding file from hal-info-20080508-1.fc9 shows
that TravelMate 230 quirks are present and extra blanks are gone.
There is even a comment in this file which says:

  NOTE: HAL removes whitespaces at the end of the sysfs and dmidecode
        output, we need to do exact string matches.

so there is a chance that they will not come back. :-)

I did not have a chance to check that on an actual installation
but from what I see required power_management quirks should work.

For F8 without an update the problem still remains.
Comment 3 Richard Hughes 2008-06-02 10:51:04 EDT
Cool, thanks.

Note You need to log in before you can comment on or make changes to this bug.