Bug 437897 - Eclipse Plug-Ins Missing
Eclipse Plug-Ins Missing
Product: Fedora
Classification: Fedora
Component: eclipse-pydev (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-17 19:20 EDT by Alex Le Dain
Modified: 2008-03-31 16:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-31 16:42:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output from "rpm -qa | grep eclipse" (1.66 KB, text/plain)
2008-03-19 19:40 EDT, Alex Le Dain
no flags Details
output from "rpm -qa | grep gcj (174 bytes, text/plain)
2008-03-19 19:41 EDT, Alex Le Dain
no flags Details
(workspace)/.metadata/.log (587.03 KB, text/plain)
2008-03-19 19:43 EDT, Alex Le Dain
no flags Details
ouput from "dir -laR .eclipse/*" (12.24 KB, text/plain)
2008-03-24 20:00 EDT, Alex Le Dain
no flags Details

  None (edit)
Description Alex Le Dain 2008-03-17 19:20:12 EDT
Description of problem:

No plug-ins are listed in fedora-eclipse. For example PyDev (eclipse-pydev
1.3.1-5) is downloaded but does not appear in NewProject or under Preferences.
Other plug-ins that might be expected such as subeclipse (1.2.4-2) are also not

Version-Release number of selected component (if applicable): eclipse 3.2.2-15

How reproducible:


Steps to Reproduce:
1. yum install eclipse-*
2. run eclipse
3. File/NewProject (PyDev project missing)
Actual results:

No project listed.

Expected results:

PyDev as project.

Additional info:
Comment 1 Jeff Johnston 2008-03-18 12:20:39 EDT
This is working fine for me with eclipse 3.2.2-15 and eclipse-pydev 1.3.1-5
Let's try and see what is different.

Could you please post the results of: "rpm -qa | grep eclipse" here in the bug
as well as "rpm -qa | grep gcj". I assume you have already verified that "which
eclipse" is returning the installed version and not a local copy.

You could try moving your .eclipse file out of the way temporarily and retrying
as sometimes this file has problems.  You can also try the -clean option.

Look at the error log (Help->About Eclipse SDK->Configuration Details->View
Error Log  to see if some error occurred in the missing plugins.  You can also
alternatively look directly at {your_workspace_path}/.metadata/.log
Comment 2 Alex Le Dain 2008-03-19 19:40:51 EDT
Created attachment 298609 [details]
output from "rpm -qa | grep eclipse"
Comment 3 Alex Le Dain 2008-03-19 19:41:36 EDT
Created attachment 298610 [details]
output from "rpm -qa | grep gcj
Comment 4 Alex Le Dain 2008-03-19 19:43:01 EDT
Created attachment 298611 [details]
Comment 5 Alex Le Dain 2008-03-19 19:44:26 EDT
This is my own machine basically a clean install of FC7 about a month ago. The
only outstanding yum updates as of today are gimp and kernel. There is no local
copy of eclipse, and the return from "which eclipse" returns /usr/bin/eclipse.

I tried moving .eclipse out of the way and the -clean option with no result.
Interestingly when I click on the Preferences Install/Update I get this error:

Unable to create the selected Preferences page.
Reason: Plug-in org.eclipse.update.ui was unable to load class

Also I tried looking at the (Help->About Eclipse SDK->Configuration
Details->View Error Log) but when I click on the Configuration Details button
nothing happens. If I click on the Plugins button I get a list of plugins and
but PyDev and subclipse are not listed amongst them.

I don't quite know how the fedora-eclipse plug-ins work but I gather there
should be directories in /usr/lib/eclipse/plugins and /usr/share/eclipse/plugins
that have all the plug-ins. These directories look ok to me, there is a smaller
list in /usr/lib/eclipse/plugins, but the pydev and subclipse directories and
files are present in /usr/share/eclipse/plugins.

I have attached the output of the two rpm queries and the metadata log file above.
Comment 6 Jeff Johnston 2008-03-20 14:04:27 EDT
(In reply to comment #5)

You have a recurring error trying to access the configuration directory under
.eclipse.  For example:

Caused by: org.eclipse.core.runtime.CoreException: Cannot create configuration
in file:/home/aledain/.eclipse/org.eclipse.platform_3.2.0/configuration/

There are other failures with the same error.  These errors should not be
happening.  Can you confirm that the directory above is a valid directory and is
write accessible to your userid: aledain which you are running Eclipse under.
Comment 7 Alex Le Dain 2008-03-24 20:00:51 EDT
Created attachment 298958 [details]
ouput from "dir -laR .eclipse/*"
Comment 8 Alex Le Dain 2008-03-24 20:10:03 EDT
All looks fine to me. I am logged in as aledain and all the permissions look
correct to me AFAIK (see the attached directory listing). The top level eclipse
directory is "drwxrwxr-x  3 aledain aledain  4096 2008-03-17 11:33 .eclipse
". I can create and modify files in these directories. Unless eclipse requires
group write permissions all would seem to be ok.
Comment 9 Jeff Johnston 2008-03-25 19:45:14 EDT
I have done some searching on the web and apparently the error can be thrown if
there is something wrong with a MANIFEST.MF file (e.g. version number isn't
standard format can cause it).

Checking your list of eclipse packages against mine, I noticed a number that I
didn't have so I started installing them one at a time.  It appears the
eclipse-sdk-nls-* packages have problems as they caused my eclipse to fail and I
couldn't see a pydev project in the New project list.  

Could you please try doing a yum remove eclipse-sdk-nls-* and reporting the results?
Comment 10 Andrew Overholt 2008-03-25 20:52:16 EDT
eclipse-sdk-nls-* is from Fedora 7 and Eclipse 3.2.x.  While it provides many
translations of the 3.3.x SDK, it should be removed if it's causing these issues.
Comment 11 Alex Le Dain 2008-03-26 03:17:51 EDT
Excellent result! All the projects are present including PyDev. PyDev also now
appears in the Preferences. And lastly the crashes associated with Preferences
Install/Update no longer happen either.

When I installed eclipse I simply did a yum install eclipse-* and some
dependency must have pulled the eclipse-sdk-nls-* files. Don't know if this
qualifies as a bug as such. Thanks very much for your help.
Comment 12 Andrew Overholt 2008-03-26 08:46:19 EDT
Nothing would have pulled in the NLS stuff.  Oh wait, you're running Fedora 7. 
Hmm.  Odd that no one else ever reported this.  Well, since the NLS stuff is
gone in Fedora 8 and no one else has ever reported this, I'm inclined to just
leave this be.
Comment 13 Jeff Johnston 2008-03-31 16:42:31 EDT
Closing this as Rawhide since F8 does not have the NLS packages which are
causing the issue.

Note You need to log in before you can comment on or make changes to this bug.