Bug 437922 - Direct rendering does not work on Lenovo T61
Direct rendering does not work on Lenovo T61
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810 (Show other bugs)
5.2
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Dave Airlie
desktop-bugs@redhat.com
: Regression
: 441569 (view as bug list)
Depends On:
Blocks: 245607 318761 RHEL5u2_relnotes
  Show dependency treegraph
 
Reported: 2008-03-18 02:16 EDT by Jane Lv
Modified: 2008-08-19 20:30 EDT (History)
10 users (show)

See Also:
Fixed In Version: RHEA-2008-0420
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:35:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (37.68 KB, text/plain)
2008-03-18 02:16 EDT, Jane Lv
no flags Details
/etc/X11/xorg.conf (802 bytes, text/plain)
2008-03-18 02:19 EDT, Jane Lv
no flags Details
output of glxinfo (4.58 KB, text/plain)
2008-03-18 02:23 EDT, Jane Lv
no flags Details
fix direct rendering with the new driver running against our old server. (2.76 KB, patch)
2008-04-02 20:20 EDT, Dave Airlie
no flags Details | Diff

  None (edit)
Description Jane Lv 2008-03-18 02:16:43 EDT
Description of problem:
Test Intel Crestline graphics driver against RHEL5.2-Beta (kernel 2.6.18-
84.el5) on Lenovo T61 laptop.

When run glxgears, I got the error messages below and glxgears ran with very 
slow speed.
libGL error: drmMap of framebuffer failed (invalid argument)
libGL error: reverting to (slow) indirect rendering
I tried to maximize and restore down the glxgears running window, X server 
aborted.

Then I checked glxinfo.  It shows "direct rendering: No".  But 
from /var/log/Xorg.0.log, direct rendering is enabled.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install RHEL5.2-Beta client on Lenovo T61.
2. Boot the system and startx
3. Open a terminal, run "#glxgears"
4. Maximize the glxgears running window.
5. Restore down the glxgears running window.
  
Actual results:
X server aborted.

Expected results:
glxgears could run smoothly.

Additional info:
The following files attached,
1. /var/log/Xorg.0.log
2. /etc/X11/xorg.conf
3. output of glxinfo
Comment 1 Jane Lv 2008-03-18 02:16:43 EDT
Created attachment 298340 [details]
/var/log/Xorg.0.log
Comment 2 Jane Lv 2008-03-18 02:19:04 EDT
Created attachment 298341 [details]
/etc/X11/xorg.conf
Comment 3 Jane Lv 2008-03-18 02:23:20 EDT
Created attachment 298342 [details]
output of glxinfo
Comment 4 Geoff Gustafson 2008-04-01 20:27:45 EDT
Jane, is this a regression from 5.1?
Comment 5 Geoff Gustafson 2008-04-01 21:19:42 EDT
Confirmed with Jane and Austin that this _is_ a regression. It also occurs on
the Weybridge desktop (Bearlake chipset). Both Bearlake and Crestline 3D were
working in 5.1.
Comment 6 Geoff Gustafson 2008-04-02 16:11:58 EDT
Jane, please try 5.1 kernel on top of RHEL5.2-beta or whatever snapshot, and see
if that fixes it.
Comment 7 Geoff Gustafson 2008-04-02 17:45:31 EDT
I just reproduced this with 5.2 Beta on a Weybridge/Bearlake box. It's using the
"intel" driver. I noticed glxgears runs unaccelerated, and X does crash when I
restore the window size. If I switch to i810 driver in xorg.conf, though,
glxgears comes up accelerated, and doesn't have the problem.

Maybe we need to consider having i810 remain the default driver for
Bearlake/Crestline in 5.2? I'm not sure what other effects this would have. But
on this box, one effect is: the i810 driver comes up in 800x600 resolution and
system-config-display offers nothing higher. The intel driver comes up in
1024x768 and supports other options like 1280x1024.

I think the kernel is off the hook for now, should probably assign to
xorg-x11-i810-drv.
Comment 8 Dave Airlie 2008-04-02 20:20:54 EDT
Created attachment 300155 [details]
fix direct rendering with the new driver running against our old server.
Comment 9 Dave Airlie 2008-04-02 20:22:32 EDT
This is a regression for new installs or anyone trying to use the new Intel
driver as opposed to the old i810 driver.

This should probably be fixed before GA, so for that please be setting the
blocker flag.
Comment 10 Jane Lv 2008-04-03 05:36:47 EDT
RHEL5.1 is using "i810" driver as the default for Bearlake/Crestline.  RHEL5.2 
is using "intel" driver as the default for Bearlake/Crestline.  Direct 
rendering works with "i810" driver.  So I tried 5.2 kernel on 5.1 system, it's 
using "i810" driver and direct rendering works.  But it doesn't work with 5.1 
kernel on 5.2 system, which is using "intel" driver.

Dave, I tried to apply your patch to 5.2-sp2 xf86-video-intel-20080119 source 
package, "configure" failed by requiring X server >= 1.3 source tree.  
Actually,X server is version 1.1 in 5.2.  Did I do something wrong with 
building the source code?

Log messages,
configure: error: Must have X server >=1.3 source tree for mode setting code.  
Please specify --with-xserver-source
Comment 11 Dave Airlie 2008-04-03 16:46:22 EDT
the kernel shouldn't matter.

this is purely the i810 vs the intel driver problem.

You need to build the 5.2 intel driver against the 5.2 X server with the
xorg-x11-server-randr-source package installed. you need to do add the patch to
the spec and do an rpm rebuild, I don't think hand building will work too well..
Comment 12 Kevin E. Martin 2008-04-07 15:23:32 EDT
FYI, I have tested Dave's patch on a T61 and an X61 laptop (both with 965GM) and
direct rendering appears to work fine.
Comment 13 Jane Lv 2008-04-07 23:23:08 EDT
Dave, thanks for your information.  I applied your patch and rebuild 5.2 driver
intel_drv.so successfully.  But direct rendering still does not work with the
new driver.

Kevin, did you use "intel" driver or "i810" driver for your test on T61?  "i810"
driver always works fine.:)

 

Comment 14 Kevin E. Martin 2008-04-08 11:00:06 EDT
(In reply to comment #13)
> Kevin, did you use "intel" driver or "i810" driver for your test on T61?  "i810"
> driver always works fine.:)

I've tested both the "intel" and "i810" drivers and direct rendering works on
both now with Dave's patch (according to glxinfo and glxgears).  We have an
internal build with Dave's patch.  Would you like to try that updated package to
see if it works for you?  FYI, I'm testing on 5.2 beta and the only updated
package is xorg-x11-drv-i810-1.6.5-9.11.el5, which includes both the i810 and
intel drivers.
Comment 15 Kevin E. Martin 2008-04-08 11:21:47 EDT
In case anyone would like to test the latest build which includes Dave's patch,
I've put it on my people page here:
  http://people.redhat.com/kem/intel/1.6.5-9.11.el5/
Comment 18 Kevin E. Martin 2008-04-08 17:52:55 EDT
*** Bug 441569 has been marked as a duplicate of this bug. ***
Comment 19 Jane Lv 2008-04-09 03:03:52 EDT
Thanks, Kevin. I tried your test package and found the ia32 one works for ia32
system, but the x86_64 one does not work for x86_64 system.  Both glxinfo and
glxgears do not work on x86_64 system.  I've tested on 5.2-beta and 5.2-sp2.(In
reply to comment #14)
> (In reply to comment #13)
> > Kevin, did you use "intel" driver or "i810" driver for your test on T61?  "i810"
> > driver always works fine.:)
> 
> I've tested both the "intel" and "i810" drivers and direct rendering works on
> both now with Dave's patch (according to glxinfo and glxgears).  We have an
> internal build with Dave's patch.  Would you like to try that updated package to
> see if it works for you?  FYI, I'm testing on 5.2 beta and the only updated
> package is xorg-x11-drv-i810-1.6.5-9.11.el5, which includes both the i810 and
> intel drivers.
> 

Thanks, Kevin. I tried your test package and found the ia32 one works for ia32
system, but the x86_64 one does not work for x86_64 system.  Both glxinfo and
glxgears do not work on x86_64 system with "intel" driver.  I've tested on
5.2-beta and 5.2-sp2.
Comment 21 Jane Lv 2008-04-22 04:26:29 EDT
Dave/Kevin, will Dave's patch be included in RHEL5.2-snapshot6?
Comment 22 Cameron Meadors 2008-04-23 14:30:40 EDT
Testing reveals that indeed i386 install works, but x86_64 does not.
Comment 24 Jane Lv 2008-04-23 23:41:59 EDT
Currently "intel" driver is not the default setting for Cantiga.  Now it's using
"vesa".  We require to set "intel" as the default driver for Cantiga.
Comment 28 Cameron Meadors 2008-04-28 14:40:14 EDT
I tested again with snap7 and xorg-x11-drv-i810-1.6.5-9.13.el5 on T61 (x86_64).
 glxgears and glxinfo both work (report and use direct rendering).  However, if
you move the glxgears window off the screen, it gets corrupted and eventually
you get a hardlocked system with a psychadelic display.  New bug or continue
with this bug?
Comment 29 Cameron Meadors 2008-04-28 14:42:43 EDT
Addendum:  lock happens from just moving the window in any way.
Comment 30 Cameron Meadors 2008-04-28 15:09:02 EDT
It does work on Cantiga and 82Q35 (bearlake?) with out issues.  T61 is the only
one with problems (DRI enabled, but crashes and hardlocks system)
Comment 31 Cameron Meadors 2008-04-28 15:37:03 EDT
Can the reporter retest to see if it works their hardware?  X crash and/or
hardlock maybe different bugs.
Comment 32 Cameron Meadors 2008-04-28 15:45:56 EDT
I filed a bug for the crash/hang: 
https://bugzilla.redhat.com/show_bug.cgi?id=444508
Comment 34 Jane Lv 2008-04-29 05:52:04 EDT
I tested RHEL5.2-snapshot6.  DRI does not work w/ x86_64 version on
Crestline/Bearlake.  Both glxinfo and glxgears shows no DRI supported in x86_64
version.

DRI works w/ i386 version and no "lock" happens in my testing w/ both Bearlake
and Crestline.

The test is also done on my T61 platform, which integrates Crestline chipset. 
DRI works well w/ i386 version, but does not work w/ x86_64 version. And no
"lock" on i386 version.
Comment 35 Cameron Meadors 2008-04-29 08:37:39 EDT
Jane, you need xorg-x11-drv-i810-1.6.5-9.13.el5.  The fix is not is snap 6 or
snap 7.
Comment 37 Don Domingo 2008-04-29 19:53:18 EDT
other than the glxgears lock issue on T61, is there any other issue WRT this bug
that needs to be documented in the release notes? BZ#444508 already tracks the
glxgears lock issue.
Comment 38 austin 2008-04-29 23:47:17 EDT
(In reply to comment #35)
> Jane, you need xorg-x11-drv-i810-1.6.5-9.13.el5.  The fix is not is snap 6 or
> snap 7.
Thanks for the info.

So that means it will be in till GA? And 'set 'intel' as default driver in 
_cantiga_ platform' will be in till GA also?
Comment 39 Cameron Meadors 2008-04-30 09:00:29 EDT
Austin, The fixes should be in the Release Candidate and of course GA.

Don,  I think the requires_release_note flag was added when we thought this was
not fixed.  I think it can be removed now.  We were able to verify this bug, but
we were waiting on the customer to double check.  The only issues is the
glxgears one you already mentioned.
Comment 40 Jane Lv 2008-05-09 04:58:31 EDT
(In reply to comment #39)
> Austin, The fixes should be in the Release Candidate and of course GA.
> 
> Don,  I think the requires_release_note flag was added when we thought this was
> not fixed.  I think it can be removed now.  We were able to verify this bug, but
> we were waiting on the customer to double check.  The only issues is the
> glxgears one you already mentioned.

Tested RHEL5.2-RC1 w/ both x86_64 and i386 version on Intel platforms,
1. "intel" is set as default driver for Cantiga.
2. DRI support for Crestline/Bearlack on both x86_64 and i386 are enabled. But
the only issue is glxgears one for Crestline.  I reproduced it on RHEL5.2-RC1.

I will verify this bug and track glxgears issue in bug
https://bugzilla.redhat.com/show_bug.cgi?id=444508.
Comment 41 errata-xmlrpc 2008-05-21 10:35:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0420.html

Note You need to log in before you can comment on or make changes to this bug.