Bug 437938 - Unable to install via ftp/http from boot.iso
Unable to install via ftp/http from boot.iso
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 06:34 EDT by Sebastian Vahl
Modified: 2008-03-20 12:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 10:10:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of TTY3 in Virtualbox (32.40 KB, image/png)
2008-03-18 06:34 EDT, Sebastian Vahl
no flags Details
Screenshot of TTY4 in Virtualbox (30.58 KB, image/png)
2008-03-18 06:43 EDT, Sebastian Vahl
no flags Details

  None (edit)
Description Sebastian Vahl 2008-03-18 06:34:38 EDT
Description of problem:
With actual boot.iso I am unable to do a http or ftp installation.

Version-Release number of selected component (if applicable):
boot.iso (18-Mar-2008 04:06 116M)

How reproducible:
ever


Steps to Reproduce:
1. Download boot.iso
2. Start boot.iso
3. Select URL installation method
4. Configure language and network
5. Enter URL and hit enter
  
Actual results:
After a few seconds the "URL Setup" screen re-appears

Expected results:
Installation should proceed.

Additional info:
In a ftp installation there is no error "bad HTTP response code" but the URL 
is also listed twice and the installation also isn't working.
Comment 1 Sebastian Vahl 2008-03-18 06:34:38 EDT
Created attachment 298362 [details]
Screenshot of TTY3 in Virtualbox
Comment 2 Sebastian Vahl 2008-03-18 06:43:31 EDT
Created attachment 298363 [details]
Screenshot of TTY4 in Virtualbox

These lines seems to be specific for the problem:
<4> ISOFS: Unabel to identify CD-ROM format.
<4> VFS: Can't find an ext2 filesystem on dev loop0.
Comment 3 Chris Lumens 2008-03-18 10:10:25 EDT
This should be fixed in anaconda-11.4.0.54.
Comment 4 Sebastian Vahl 2008-03-18 10:29:25 EDT
(In reply to comment #3)
> This should be fixed in anaconda-11.4.0.54.

So the actual boot.iso is created with an older version of anaconda? If so, 
when will an updated version be available? After the next rawhide push?

Comment 5 Will Woods 2008-03-18 12:42:45 EDT
Rawhide is created using the anaconda-runtime package that's in the tree that day. So today's tree, which 
has anaconda-runtime-11.4.0.54, *should* have a boot.iso that works.

Now, whether your local mirror has *today's* tree.. is a different question. The simplest way to check is to 
do:
  yum install snake
  snake-tree info [mirrorurl, like http://mirrors.kernel.org/fedora/development/i386/os/]
and check the Name and Time lines - they'll be something like:
Fedora development i386 (20080318), 2008-03-18 04:03 EDT
Comment 6 Sebastian Vahl 2008-03-18 13:23:09 EDT
(In reply to comment #5)
> Rawhide is created using the anaconda-runtime package that's in the tree 
that day. So today's tree, which 
> has anaconda-runtime-11.4.0.54, *should* have a boot.iso that works.

Not here. And the url I've used was:
http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os

> Now, whether your local mirror has *today's* tree.. is a different question. 
The simplest way to check is to 
> do:
>   yum install snake
>   snake-tree info [mirrorurl, like 
http://mirrors.kernel.org/fedora/development/i386/os/]
> and check the Name and Time lines - they'll be something like:
> Fedora development i386 (20080318), 2008-03-18 04:03 EDT

Ok. Thanks. My local copy was still from yesterday. However, it also don't 
work with download.fedora.redhat.com.

I'll wait for the next push and try it again then.

Comment 7 Sebastian Vahl 2008-03-18 13:38:40 EDT
Err. I mixed up my boot.iso's. It's now also working here.
Comment 8 Bruno Wolff III 2008-03-20 10:39:22 EDT
It seems to have been rebroken as I haven't been able to do URL install's with
boot.iso images from either the 19th or 20th.
Anaconda tries to get .discinfo and then after getting a 404 stops making
requests and goes back to the URL entry page. Here is the http log entry:
192.168.0.2 - - [20/Mar/2008:09:06:30 -0500] "GET /fd64/.discinfo HTTP/1.0" 404
288 "-" "anaconda/11.4.0.55"
As far as I can tell .discinfo isn't in the rawhide repository. In the past URL
installs worked without it.
Comment 9 Chris Lumens 2008-03-20 11:14:15 EDT
That check's not really important anymore because we allow you to modify your
repo choice later if you didn't use the correct URL in loader.  So it's been
removed.
Comment 10 Bruno Wolff III 2008-03-20 12:00:13 EDT
OK I see this change has been committed to the git repository. I'll just fudge
.discinfo to do my install today. If this one works as expected I am going to
start really using the machine and  won't be able to retest in the near future.
Thanks for the followup.

Note You need to log in before you can comment on or make changes to this bug.