Bug 437941 - rhn_check hang when creating xen guest from webui
rhn_check hang when creating xen guest from webui
Status: CLOSED DUPLICATE of bug 364491
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization (Show other bugs)
520
All Linux
low Severity low
: ---
: ---
Assigned To: Devan Goodwin
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 07:03 EDT by Miroslav Suchý
Modified: 2008-08-18 23:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 11:02:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of rhn_check -vvv (25.43 KB, application/octet-stream)
2008-03-18 07:10 EDT, Miroslav Suchý
no flags Details
relevant lines from /var/log/xen/xend.log (7.93 KB, application/octet-stream)
2008-03-18 07:13 EDT, Miroslav Suchý
no flags Details

  None (edit)
Description Miroslav Suchý 2008-03-18 07:03:01 EDT
Description of problem:
rhn_check hang when creating xen guest from webui. For more details see Steps to
reproduce

Version-Release number of selected component (if applicable):
501

How reproducible:
always

Steps to Reproduce:
1. create PV KS profile
2. SystemDetails->Virtualization->Provisioning
3. Schedule creation of new Virtual system
4. run rhn_check on host
  
Actual results:
rhn_check hang forever

Expected results:
rhn_check will finish in finite time

Additional info:
$ps axf
...
 4655 pts/0    Ss     0:00  |   \_ -bash
12930 pts/0    Sl+    0:00  |       \_ /usr/bin/python /usr/sbin/rhn_check
13063 pts/0    Sl+    0:01  |           \_ /usr/lib/xen/bin/xenconsole 5
13064 pts/0    Sl+    0:00  |           \_ /usr/bin/python /usr/sbin/rhn_check
...

When I manualy do 
  kill 13063
rhn_check will finish.
Comment 1 Miroslav Suchý 2008-03-18 07:10:06 EDT
Created attachment 298370 [details]
Output of rhn_check -vvv


See  line 
<------ here I manually killed xenconsole
where I manualy killed xencosole and rhn_check continued and then finaly
finished.
Comment 2 Miroslav Suchý 2008-03-18 07:13:48 EDT
Created attachment 298372 [details]
relevant lines from /var/log/xen/xend.log
Comment 3 Devan Goodwin 2008-03-18 11:02:39 EDT
I think this is a dupe that's been fixed in Satellite 5.1. We had code go out in
5.0 that worked at the time but later broke with updates to libvirt in RHEL 5.1
causing this hung xenconsole process. The unpredictable code was removed in Sat
5.1 in favor of something much more consistently reliable.

*** This bug has been marked as a duplicate of 364491 ***

Note You need to log in before you can comment on or make changes to this bug.