Bug 437949 - [PATCH]: DHCPV6C should allow passing arguments to DHCPV6C
[PATCH]: DHCPV6C should allow passing arguments to DHCPV6C
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.1
All Linux
low Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 08:17 EDT by Pekka Savola
Modified: 2014-09-08 07:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:14:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dhcpv6c allow passing arguments, fix the code in other ways (1.34 KB, text/plain)
2008-03-18 08:17 EDT, Pekka Savola
no flags Details

  None (edit)
Description Pekka Savola 2008-03-18 08:17:48 EDT
Description of problem:

The current initscripts framework does not allow passing DHCPv6 client
arguments.  There is need to pass especially '-I' argument, which makes the
client ask for network information only (e.g. DNS and NTP options), not try to
configure addresses using DHCPv6.

This option is needed in environments where address assignment is done using
manual or stateless address autoconfiguration yet DNS information is provided
(in a stateless manner, see RFC3736) to client hosts.

Version-Release number of selected component (if applicable):
5.1.

How reproducible:
grep dhcp6c /etc/sysconfig/network-scripts/ifup-eth

Steps to Reproduce:
1. grep dhcp6c /etc/sysconfig/network-scripts/ifup-eth
2.
3.
  
Additional info:

Patch is provided that adds DHCPV6C_OPTIONS that allows passing the argument.

This would be great to have in RHEL 5.2 but may be too late.
This problem also affects Fedora 8.

The patch also makes two other changes:
 - it removes two unnecessary ';'s from the end of lines (cleanup)
 - saves the PID number only if there was any output.  In case dhcp6c crashes
when it's starting (and ${dhcp6_pid[0]} ends up being empty) there will be error
messages when in ifdown the code tries to use the empty pid file to kill a process.

NB: it might be better idea to change the ps matching to something like
"/bin/grep "dhcp6c.* ${DEVICE}" so that if the arguments get changed, the
matching still works.  I didn't do this because the existing mechanism is
already somewhat brittle (e.g., if you disable dhcpv6 and take interface down,
the dhcpv6 client is not killed).
Comment 1 Pekka Savola 2008-03-18 08:17:49 EDT
Created attachment 298385 [details]
dhcpv6c allow passing arguments, fix the code in other ways
Comment 2 Bill Nottingham 2009-03-20 12:49:43 EDT
Yeah, the pid stuff is ugly, but no less broken than before. Added to HEAD, looks reasonable for RHEL 5.x.

http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=f0003e3a245686929791b50896b2a4b22ff689a9
Comment 4 Harald Hoyer 2009-05-05 08:50:55 EDT
Please test the erratum candidate:
http://people.redhat.com/harald/downloads/initscripts/initscripts-8.45.26.1.el5/
Comment 6 Pekka Savola 2009-05-27 04:44:23 EDT
Sorry for delay in responding.  Unfortunately right now I don't have access to a network where I could test this for sure.  But go ahead for all of me :-)
Comment 9 errata-xmlrpc 2009-09-02 07:14:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1344.html

Note You need to log in before you can comment on or make changes to this bug.