Bug 437952 - "liveinst --debug" fails with backtrace
"liveinst --debug" fails with backtrace
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-18 08:40 EDT by Sebastian Vahl
Modified: 2008-03-18 13:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 13:12:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2008-03-18 08:40:15 EDT
Description of problem:
If you want to start liveinst in debugging mode to get some more informations, 
it fails with a backtrace:

$ liveinst --debug
FATAL: Module md not found.
  No volume groups found
> /usr/sbin/anaconda(812)<module>()
-> import instdata
(Pdb)
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 812, in <module>
    import instdata
  File "/usr/sbin/anaconda", line 812, in <module>
    import instdata
  File "/usr/lib/python2.5/bdb.py", line 48, in trace_dispatch
    return self.dispatch_line(frame)
  File "/usr/lib/python2.5/bdb.py", line 67, in dispatch_line
    if self.quitting: raise BdbQuit
bdb.BdbQuit


Version-Release number of selected component (if applicable):
anaconda-11.4.0.54-1.i386

How reproducible:
ever

Steps to Reproduce:
1. liveinst --debug
  
Actual results:
backtrace

Expected results:
works
Comment 1 Jeremy Katz 2008-03-18 13:12:27 EDT
--debug to anaconda drops you into pdb early on.  Due to how the live install
process works, we end up with stdin redirected and so pdb isn't usable.

Realistically --debug mode isn't that interesting for most cases and for the few
that it is, it's easy enough to start anaconda by hand with the right args

Note You need to log in before you can comment on or make changes to this bug.